Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#4835 closed defect (rejected)

ABP crashing in chrome canary Version 58.0.2990.0

Reported by: mapx Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords: externaldependency
Cc: kzar, sebastian, greiner, cokie69 Blocked By:
Blocking: Platform: Chrome
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

w10
chrome Version 58.0.2990.0 canary (64-bit)
ABP stable 1.12.4 or dev build 1.12.4.1724

How to reproduce

install ABP
eventually restart chrome canary
ABP is crashing, in the extensions page is disabled (can press "reload" button" but crashing again)

Change History (9)

comment:1 Changed 3 years ago by mapx

  • Summary changed from ABP crashing in chrome canary Version 58.0.2990.0 canary (64-bit) to ABP crashing in chrome canary Version 58.0.2990.0

comment:2 Changed 3 years ago by kzar

Apparently there is not a canary build for Linux so I can't (easily) test this.

Since the canary builds are built daily it sounds like this could well be a Chrome regression. Is Chrome crashing entirely? If so I think you should definitely report the problem to the Chromium guys.

If it's not entirely crashing Chrome but just saying that the extension has been disabled due to a crash then let me know and I'll see if I can reproduce the problem and see if there's anything we can do our end.

Either way thanks for reporting the problem, it's really useful to get an early warning about a potential problem.

Thanks, Dave.

comment:3 Changed 3 years ago by mapx

It's crashing only ABP. Tried also another blocking extension (ubo) ==> no issue it's working fine.
In console I see ...nothing (or I dont know how to catch such event)

Last edited 3 years ago by mapx (previous) (diff)

comment:4 Changed 3 years ago by cokie69

Dave, I can confirm the same problem under the same scenario.

Only ABP crashes, not Chrome.

comment:5 Changed 3 years ago by mapx

  • Cc cokie69 added

comment:6 Changed 3 years ago by kzar

Interesting OK, will get a virtual machine fired up and try to reproduce :/

comment:7 Changed 3 years ago by kzar

  • Keywords externaldependency added
  • Ready set
  • Resolution set to rejected
  • Status changed from new to closed

I can reproduce this but it looks like a Chromium regression since I'm getting a nullptr error when I enable logging. I've filed an issue on their tracker: https://bugs.chromium.org/p/chromium/issues/detail?id=684396

Thanks again for reporting, if you have a minute please star the issue on their tracker and hopefully they'll take care of this for us.

comment:8 Changed 3 years ago by mapx

it seems all fine with the last canary
Version 58.0.2992.0 canary (64-bit)

comment:9 Changed 3 years ago by kzar

Thanks, that's good to know.

The Chromium tester had a go at reproducing the issue and failed, I've pushed him to try again since everyone here managed to reproduce. It would be reassuring if he could confirm the regression was fixed and when it was fixed.

Note: See TracTickets for help on using tickets.