Opened 3 years ago

Closed 3 years ago

#4836 closed defect (fixed)

Buildtools uses an old URL for checking allowed Crowdin locales

Reported by: kzar Assignee: kzar
Priority: P2 Milestone:
Module: Automation Keywords:
Cc: sebastian, trev, kvas Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29372826/

Description (last modified by trev)

Environment

Buildtools 8a2661537ab7

How to reproduce

  1. Type ./build.py -t generic setuptrans APIKEY from a repository, for example adblockplusui. (After being careful to alter the basename setting in metadata.genreic so that the real Crowdin project is not used!)

Observed behaviour

An exception is thrown since the http://crowdin.net/page/language-codes page no longer exists.

Expected behaviour

No exception is thrown, the target languages are updated properly.

Notes

Change History (4)

comment:1 Changed 3 years ago by kzar

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 3 years ago by trev

  • Description modified (diff)

comment:3 Changed 3 years ago by abpbot

comment:4 Changed 3 years ago by kzar

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.