Opened 3 years ago

Closed 3 years ago

#4840 closed defect (duplicate)

"Block Element" tool fails to remove some grey overlay elements

Reported by: pfrey Assignee:
Priority: P3 Milestone:
Module: Platform Keywords:
Cc: sebastian, kzar, mapx, arthur, fanboy, greiner Blocked By:
Blocking: Platform: Chrome
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by kzar)

Environment

Windows 10, Chrome Version 55.0.2883.87 m (64-bit) or Firefox

How to reproduce

  1. Go to http://www.horizont.net/agenturen/nachrichten/Wahlwerbung-2017-Was-Mediaagentur-Chefs-von-den-deutschen-Parteien-erwarten-145585
  2. Go into Block Element Mode and select the overlay which stops you reading the article.
  3. Click OK.

Observed behaviour

The overlay element is not removed.

Expected behaviour

The overlay element should be removed.

Note: Since the elements have random class / IDs the filter will not work when the page is refreshed. However the element should still be deleted when first selected using the tool. (With uBlock that does work.)

Change History (8)

comment:1 Changed 3 years ago by mapx

  • Cc mapx arthur fanboy added
  • Component changed from Unknown to Platform

comment:2 Changed 3 years ago by mapx

random placed divs / classes

fixable using

@@||horizont.net^$generichide

or

||laterpay.net^$domain=horizont.net

comment:3 Changed 3 years ago by mapx

  • Summary changed from Horizont Anti Adblock Overlay not removable with ABP (but with uBlock) to Horizont Anti Adblock Overlay not removable

comment:4 Changed 3 years ago by mapx

  • Component changed from Platform to Unknown
  • Description modified (diff)
  • Platform changed from Chrome to Unknown / Cross platform

comment:5 Changed 3 years ago by kzar

  • Component changed from Unknown to Platform
  • Description modified (diff)
  • Platform changed from Unknown / Cross platform to Chrome
  • Priority changed from Unknown to P3
  • Ready set
  • Summary changed from Horizont Anti Adblock Overlay not removable to "Block Element" tool fails to remove some grey overlay elements

comment:6 Changed 3 years ago by kzar

  • Description modified (diff)

comment:7 Changed 3 years ago by greiner

  • Cc greiner added

FYI: uBlock Origin accomplishes to hide the element because it modifies the DOM element, adding display: none !important to its style attribute. I doubt that this workaround is something we'd like to replicate due to the fact that it's inconsistent with the way how element hiding works.

With this upcoming change in Chromium, however, this issue should resolve itself as soon as we start to make use of it.

comment:8 Changed 3 years ago by kzar

  • Resolution set to duplicate
  • Status changed from new to closed

OK that makes sense, I agree. Therefore this issue is a duplicate of #242, when that's fixed this will be too.

Note: See TracTickets for help on using tickets.