Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#4908 closed defect (fixed)

ABB crashes during start-up on older devices

Reported by: mario Assignee:
Priority: P1 Milestone: Adblock-Browser-for-iOS-1.5.2
Module: Adblock-Browser-for-iOS Keywords:
Cc: jand Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: no Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

Description (last modified by mario)

Here is a list to complete the device and iOS versions for checking -

Crashing on startup are:

iPad 2 - iOS 9.3.3 (virtual)
iPad 2, iOS 9.3.3 (physical)
iPad 2, iOS 9.3.2 (physical)
iPhone 5 - iOS 8.3 (virtual)
iPhone 5 - iOS 8.3 (physical)
iPhone 5c - iOS 9.3.4 (virtual)
iPhone 5c - iOS 9.1 (physical)
iPad Mini - iOS 9.3.2 (virtual)
iPad Mini 2 - iOS 8.3 (virtual)
iPad 3 - iOS 8.3 (virtual)
iPad 4 - iOS 9.3.3 (virtual)
iPhone 6s Plus - iOS 8.3 (virtual)

Startup with no issues are:

iPhone SE - iOS 9.3.4 (virtual)
iPhone 7 - iOS 10.0.2 (virtual)
iPhone 6S Plus - iOS 10.0.2 (physical)
iPhone 6S - iOS 9.3.4 (physical)
iPad Air 2 - iOS 9.3.2 (virtual)
iPad Pro - iOS 9.3.3 (virtual)
iPhone 5S - 9.3.4 (virtual)
iPad Air 2 - iOS 9.3.2 (virtual)
iPhone 6 - iOS 10.2.1 (physical)

Environment

ABB 1.5.2 (1421)
Devices: see list above

How to reproduce

  1. Install ABB 1.5.2 (1421)
  2. Start ABB

Observed behaviour

ABB crashes during start-up

Expected behaviour

ABB doesn't crash during start-up

Attachments (3)

Change History (18)

comment:1 Changed 4 months ago by mario

  • Summary changed from ABB crashes on start-up with older devices to ABB crashes during start-up on older devices

comment:2 Changed 4 months ago by mario

  • Description modified (diff)

comment:3 Changed 4 months ago by scheer

  • Description modified (diff)

comment:4 Changed 4 months ago by mario

  • Description modified (diff)

comment:5 Changed 4 months ago by pavelz

iPad Pro - iOS 10.2 (physical) does not crash

comment:6 Changed 4 months ago by pavelz

Dependency framework AttributedMarkdown was left to default "deployment target" which rendered to 10.2. ABB app itself is still set to and supporting down to 8.0

comment:7 Changed 4 months ago by pavelz

  • Resolution set to fixed
  • Status changed from new to closed

comment:8 Changed 4 months ago by pavelz

  • Milestone set to Adblock-Browser-for-iOS-1.5.2

comment:9 Changed 4 months ago by pavelz

  • Resolution fixed deleted
  • Status changed from closed to reopened

Still crashes in bootstrap on 8.4.1 (Salsita iPhone 5c). See the attached log.
I could not reproduce it through sideload debugging.

Changed 4 months ago by pavelz

comment:10 Changed 4 months ago by pavelz

Sorry wrong log, incomplete symbols, see the next one.

comment:11 Changed 4 months ago by pavelz

  • Cc jand added

comment:12 Changed 4 months ago by scheer

  • Tester changed from Unknown to Scheer
  • For the most part, all devices listed below are still crashing with the latest 1.5.2-devbuild (1431), but as mentioned before, the behavior with the iOS 8 devices are slightly different. The iOS 8 devices mostly don't load either and crash, but 1 out of 5 times or so, the app actually loads (unlike the ioS9.0+ devices where the crash immediately 100% of the time).

No crash reports were prompted to be sent.

Still crashing on startup are:

iPad 2 - iOS 9.3.3 (virtual)
Still Crashes
iPad 2, iOS 9.3.3 (physical)
Not Tested (No Physical Device Available)
iPad 2, iOS 9.3.2 (physical)
Not Tested (No Physical Device Available)
iPhone 5 - iOS 8.3 (virtual)
Still Crashes
iPhone 5 - iOS 8.3 (physical)
Not Tested (No Physical Device Available)
iPhone 5c - iOS 9.3.4 (virtual)
Still Crashes
iPhone 5c - iOS 9.1 (physical)
Not Tested (No Physical Device Available)
iPad Mini - iOS 9.3.2 (virtual)
Still Crashes
iPad Mini 2 - iOS 8.3 (virtual)
Crashed two times, but fully loaded on the third try.
iPad 3 - iOS 8.3 (virtual)
Still Crashes
iPad 4 - iOS 9.3.3 (virtual)
Still Crashes
iPhone 6s Plus - iOS 8.3 (virtual)
Still Crashes

comment:13 Changed 4 months ago by pavelz

@scheer please retest build 1435
https://rink.hockeyapp.net/manage/apps/185237/app_versions/110
I have just published it.
I will not close the issue as usual and leave it to the result of retesting

comment:14 Changed 4 months ago by pavelz

  • Cc scheer added
  • Resolution set to fixed
  • Status changed from reopened to closed

Alright closing as usual, to signal retestability. Also added Scott to cc. I still don't remember if being an appointed tester means that the person is being cced or not.

comment:15 Changed 4 months ago by scheer

  • Cc scheer removed
  • Verified working set

Below are the results of the new test run on TO. As you can see, there appears to be an issue TO side with regards to the app initialising on VM startup, of which we need to look into. Although my results state 'works on startup 3/5 etc', the true fact is that this issue is now resolved, as the app actually starts, which was the point of this issue in the first place.

iPad 2 - iOS 9.3.3 (virtual)
Loads when manually selected on device (does not auto load on device startup)

iPad 2, iOS 9.3.3 (physical)
Not Tested (No Physical Device Available)

iPad 2, iOS 9.3.2 (physical)
Not Tested (No Physical Device Available)

iPhone 5 - iOS 8.3 (virtual)
Loads on startup 3/5 times. (Thereafter, only loads after manual selection of app)

iPhone 5 - iOS 8.3 (physical)
Not Tested (No Physical Device Available)

iPhone 5c - iOS 9.3.4 (virtual)
Loads on startup 2/5 times. (Thereafter, only loads after manual selection of the app)

iPhone 5c - iOS 9.1 (physical)
Not Tested (No Physical Device Available)

iPad Mini - iOS 9.3.2 (virtual)
Loads on startup 4/5 times. (Thereafter, only loads after manual selection of the app)

iPad Mini 2 - iOS 8.3 (virtual)
Loads on startup 5/5 times. (Thereafter, only loads after manual selection of the app)

iPad 3 - iOS 8.3 (virtual)
Loads on startup 2/5 times. (Thereafter, only loads after manual selection of the app)

iPad 4 - iOS 9.3.3 (virtual)
Loads on startup 5/5 times. (Thereafter, only loads after manual selection of the app)

iPhone 6s Plus - iOS 8.3 (virtual)
Loads on startup 4/5 times. (Thereafter, only loads after manual selection of the app)

Note: See TracTickets for help on using tickets.