Opened 3 years ago

Closed 2 years ago

#4912 closed defect (fixed)

Update media coverage links on eyeo.com

Reported by: jeen Assignee: ire
Priority: P2 Milestone:
Module: Websites Keywords: goodfirstbug
Cc: Rotem, ben, saroyanm, juliandoucette, wspee, ire Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29499714/

Description (last modified by jeen)

On the eyeo.com homepage, under "Media coverage" we link to 8 different news articles. 1 of the links is broken (Wired) and another prevents the user from accessing the article with a Paywall (FT), the remaining items link to old articles from 2012/ 2013. The media coverage items should link to more recent articles as specified below.

Secondly, all links take the user to the article, away from the eyeo website. The article links should open in a new tab, or if already open in a new tab, should take users to the respective tab.

How to reproduce

  1. Go to eyeo.com
  2. Scroll down to Media coverage
  3. Click on publication logo

Observed behaviour

Clicking on any of the links brings the user to the article page, away from eyeo.com.

Expected behaviour

Assets

https://drive.google.com/drive/u/1/folders/0B6JiSEX_2yllc1dvOUp5UUlxUlU

Change History (19)

comment:1 Changed 3 years ago by jeen

  • Cc juliandoucette added; julian@… removed
  • Description modified (diff)

comment:2 Changed 3 years ago by juliandoucette

  • Description modified (diff)

The article links should open in a new tab, or if already open in a new tab, should take users to the respective tab.

I don't think we should be so specific.

  • We can't override the users choice about new tab vs new window
  • We can't override the users choice about new tabs/windows taking focus
  • I don't think we should override the users choice about opening a link separately

comment:3 Changed 3 years ago by jeen

I think we should still open the media links in a new tab/window - whichever the user choice is, but we should not take them away from the main website. They came to the website for a specific reason, and taking them to a different site altogether is only going to take them away from the main task at hand.

comment:4 Changed 3 years ago by juliandoucette

  • Keywords goodfirstbug added
  • Priority changed from Unknown to P3
  • Ready set

comment:5 Changed 2 years ago by juliandoucette

  • Owner set to juliandoucette

comment:6 Changed 2 years ago by juliandoucette

  • Cc wspee iaderinokun added
  • Owner juliandoucette deleted
  • Priority changed from P3 to P2
  • Ready unset

Can you provide the logos please?

  • 100px height
  • proportional width
  • png
  • consistent whitespace

(Lay them out in your image editor so that you know how they look beside each other.)

comment:7 Changed 2 years ago by ire

  • Cc ire added; iaderinokun removed

comment:8 Changed 2 years ago by jeen

@pfrey would you be able to provide the logo assets for this?

comment:9 Changed 2 years ago by jeen

  • Description modified (diff)

comment:10 Changed 2 years ago by jeen

@ire @

Added links to the assets in the description above.

comment:11 Changed 2 years ago by ire

Thanks @jeen , the images look good to me.

Regarding opening links in a new tab, here is the concern:

  1. Users who want to open a link in a new tab always have the option to manually do that themselves. Forcing a link to open in a new window removes that choice from the user
  2. In cases where we agree we want the link to open in a new tab, we would want to make it clear to the user that this will happen. We would typically do this in our markup (for screen reader users) as well as visually (e.g. placing an external link icon next to the link). In this particular case, the visual representation is more problematic since the links are images.

To solve the second issue I can suggest showing the icon overlaid on the image on hover (what do you think @juliandoucette?), but that doesn't solve the first issue.

comment:12 Changed 2 years ago by jeen

@ire I understand your point, however, I would argue that these are media links which are to external sites/articles, therefore, it is important that we do not take users away from our website.

Users don't always intuitively manually open links in new tabs even if that was their intention since many sites do that now. It is also far more frustrating to be brought away from your page and having to navigate back to where you were before than simply closing a tab. If it is a navigation element where the user is intentionally trying to access a very specific content within the site, then absolutely the link should not open in a new tab.

However, in this case, the links are to articles this a more exploratory behaviour where it is unclear what kind of content is behind each link. Therefore, in this case, it should open in a new tab. I also would argue for links to external sites, users often expect links to open in a new tab.

I like the idea of having a hover over to make it clear that the article will open in a new tab.

comment:13 Changed 2 years ago by juliandoucette

  • Ready set

I like the idea of having a hover over to make it clear that the article will open in a new tab.

Agreed.

I'm still not convinced that we should ever force external links to open in new windows or tabs. But Jeen's opinion takes precedence here and I'd rather update the content first and the function later if necessary.

comment:14 Changed 2 years ago by ire

  • Owner set to ire

comment:15 Changed 2 years ago by ire

@jeen Please confirm, am I replacing all the articles with the ones specified, or just updating the broken links etc. For example, will the article from the Economist remain? If so, could I get updated logos for all the publications as the current ones aren't the best quality.

comment:16 Changed 2 years ago by jeen

@ire we are replacing all the articles with the ones specified in this ticket. You should have all the assets for the new articles. Let me know if any are missing.

comment:17 Changed 2 years ago by ire

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:18 Changed 2 years ago by abpbot

A commit referencing this issue has landed:
Issue 4912 - Update media coverage links on eyeo.com

comment:19 Changed 2 years ago by ire

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.