Opened 3 years ago

Closed 3 years ago

#4914 closed defect (duplicate)

Returning from iTunes to web page states 'Back to Adblock'

Reported by: scheer Assignee:
Priority: Unknown Milestone:
Module: Adblock-Browser-for-iOS Keywords:
Cc: mario, pavelz Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: no Confidential: no
Tester: Scheer Verified working: no
Review URL(s):

Description

When the user is directed to iTunes from ABB iOS, an option is displayed at the top left of the screen to return back to the browser. This should state something along the lines of 'ABB iOS' or Adblock Browser'. Currently, this states 'Back to Adblock'.

Environment

ABB iOS 1.5.2-devbuild (1431)
iPhone 6s
iOS 9.3.4

How to reproduce

  1. Visit http://www.yahoo.com
  2. Select the mail icon at the top of the page
  3. Select to install the suggested Yahoo mail app

Observed behaviour

'Back to Adblock' is displayed

Expected behaviour

'Back To Adblock Browser' Should be displayed.

Attachments (1)

image1 (1).PNG (1.4 MB) - added by scheer 3 years ago.

Download all attachments as: .zip

Change History (5)

Changed 3 years ago by scheer

comment:1 Changed 3 years ago by mario

  • Cc pavelz added

@pavelz, I assume this is due to the fact, that the app itself is called "Adblock". Is there any way to state a different name for those instances or would we need to rename the whole app?

comment:2 Changed 3 years ago by pavelz

The "Back to X" facility is driven by iOS, not by the app X, so there is no way to influence the exact string. Other than renaming the app, sure. Why is "Back to Adblock" wrong? "Back to Adblock Browser" won't fit in there.

comment:3 Changed 3 years ago by pavelz

Ok i tried with "Opera Mini" which is the only browser with somewhat longer name, and iOS displays just "Opera Mini" instead of "Back to Opera Mini". But the issue is the same: iOS uses the name of the app. "Adblock Browser" was not used because it does not fit in the single line allocated to each app icon in the iOS dashboard. "ABB iOS" would be applicable but it's a silly app name to show in dashboard.

comment:4 Changed 3 years ago by mario

  • Resolution set to duplicate
  • Status changed from new to closed

Closing this as a "duplicate" of #4929. This will be fixed once #4929 landed, as we decided to globally name the app "Adblock Browser" instead of "Adblock" in some instances.

Note: See TracTickets for help on using tickets.