Opened 5 years ago

Closed 5 years ago

Last modified 3 years ago

#496 closed defect (incomplete)

ABP causes Youtube stalls on Chrome-HTML5

Reported by: smartydix Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: smultron45@…, greiner, arthur, sebastian Blocked By:
Blocking: Platform:
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

Windows 8
Chrome Version 34.0.1847.137 m
Adblock Plus 1.8.1
EasyList

How to reproduce

  1. Go to http://youtube.com/
  2. Sign in*

Observed behaviour

The page simply becomes unresponsive (in some cases even up to 10 seconds)

Expected behaviour

Nothing special happens

Note

*This can also be reproduced by opening any Youtube video page, except it happens only a few seconds after the video starts playing. Also, in my case everything is fine if I'm not signed in, hence the (2. Sign in)

Attachments (1)

youtube-elemhide.txt (233.3 KB) - added by sebastian 5 years ago.

Download all attachments as: .zip

Change History (20)

comment:1 Changed 5 years ago by mapx

  • Cc smultron45@… added

comment:2 Changed 5 years ago by mapx

other reports:
"YouTube videos freezing after 4 seconds in Chrome/HTML5"
https://adblockplus.org/forum/viewtopic.php?f=10&t=23129

comment:3 Changed 5 years ago by mister k

I have the same issue.
I have windows 8.1 thou.. the rest is the same.

https://adblockplus.org/forum/viewtopic.php?f=10&t=23129

Last edited 5 years ago by mister k (previous) (diff)

comment:4 Changed 5 years ago by greiner

  • Cc greiner added

comment:5 Changed 5 years ago by greiner

I'm experiencing the same behavior using the latest development build (rev 1188) and in v1.8.1. This issue does not occur if there are no filter lists enabled.

Last edited 5 years ago by greiner (previous) (diff)

comment:6 Changed 5 years ago by cormac596

Getting the same problem. Win 7, html5, chrome, i5 3350p, gtx 650.

comment:7 Changed 5 years ago by sebastian

Either this issue isn't new or it is triggered by a recent change on YouTube. greiner told me that he can notice some hiccups on YouTube also with Adblock Plus 1.7.4. But apparently since we started to use Shadow DOM in Adblock Plus (#309), the hiccups of ~0.5s became lags of ~5s. That means that we can't completely eliminate the issue by removing or optimizing our Shadow DOM code.

However the issue seems to disappear when using less filter rules. So I'm hoping that there are some specific filter rules responsible for that behavoir that we can just remove or whitelist, to fix this issue.

comment:8 Changed 5 years ago by xraiderv1

my filterlist is easylist, my version of google chrome is 34.0.1847.137 m, my os is windows vista

I am getting load times of up to a minute now..on youtube.com, never mind any of the video pages.

I disabled abp and reloaded the page and presto instant load, reenable, and back to minute long page loads.

either something was changed in chrome as there was an update pushed within the past few days, something was changed in abp, or its on youtube's end.

comment:9 Changed 5 years ago by akillj

Yes, I am having the same issue, been trying to narrow it down all day and finally figured out it's ABP. Win7, Easylist, HTML5, Chrome, Vishera x6 on a 7870. Every Youtube video's video feed freezes from 2/3/4 to 8/9/10 seconds, while the audio continues. After this time the video will snap to where it's supposed to be (at 10 seconds or so).

comment:10 Changed 5 years ago by tevertist

I had the same problem mentioned above when using the YouTube website with Adblock Plus and EasyList.

However, when I tested the YouTube website with the other Google Chrome Adblock extension and EasyList, I did not experience the problem with YouTube.

This is the "other" Google Chrome Adblock extension I am referring to:
https://chrome.google.com/webstore/detail/adblock/gighmmpiobklfepjocnamgkkbiglidom?hl=en

Specifications:
Google Chrome 34.0.1847.137
Linux

comment:11 Changed 5 years ago by arthur

  • Cc arthur added

I can reproduce this as well.

When I whitelist element hiding completely by @@||youtube.com^$elemhide, it works fine. But if you whitelist all active element hiding filters individually by #@##ad_creative_3, #@##footer-ads, #@#.ad-div and #@#.masthead-ad-control, it's still hanging for me.

Changed 5 years ago by sebastian

comment:12 Changed 5 years ago by sebastian

Note that CSS selectors are also added for filters that don't match, and might still have an effect on the performance. Here is the list of all element hiding filters that are used on YouTube. Can you please try what happens if you disable all filter lists and configure those as custom filters? If the issue persits, please test what happens when you just add a subset of those filters.

comment:13 Changed 5 years ago by arthur

Got the resposible filter: ##.ob_dual_right > .ob_ads_header ~ *

Any idea why this doesn't happen in AdBlock?

comment:15 Changed 5 years ago by sebastian

I'm not surprised, that a CSS selector that applies ~ (preceded by) on * (everything), has huge performance implications. Do we really need to apply that filter on every domain? And is there no more efficient way to write that filter? Feel free to point me to some ads that are blocked with that filter.

Also can you please check whether it really doesn't make a difference with AdBlock? I would rather expect a similar behavior as greiner reproduced with Adblock Plus 1.7.4, where the issue also exists, but with lags of only ~0.5s instead ~5s. That the lag increased to 5s has something to do with using Shadow DOM (#309), which we started to use in Adblock Plus 1.8.

comment:16 Changed 5 years ago by sebastian

  • Cc sebastian added

comment:17 Changed 5 years ago by rickyshade

I just want to add that I did remove Easylist, add Easylist, and update Easylist, and now the problem is fixed.

Last edited 5 years ago by rickyshade (previous) (diff)

comment:18 Changed 5 years ago by arthur

  • Resolution set to invalid
  • Status changed from new to closed

I don't notice any lag with AdBlock.

I made the filter more specific now: https://hg.adblockplus.org/easylist/rev/6407de4c2c1d

I marked it as "invalid" since it was a filter issue.

comment:19 Changed 3 years ago by mikkuss

OK - now i know. Adblock makes it not responding because he blocks the ads (these video ads on yt also), so they don't play, but still you have to wait 5 seconds to see the clip. It is nice for me.

Note: See TracTickets for help on using tickets.