Opened 2 years ago

Closed 2 years ago

#4962 closed defect (fixed)

adblockpluscore test hang

Reported by: hfiguiere Assignee: hfiguiere
Priority: Unknown Milestone:
Module: Core Keywords:
Cc: Blocked By:
Blocking: #3143 Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29378674/

Description

Environment

This in on stock Fedora 25. I don't have a macOS env yet to test.

How to reproduce

  1. npm test

Observed behaviour

Test hang:

% npm test

> adblockpluscore@ test /home/hub/source/eyeo/adblockpluscore
> node test_runner.js

elemHideEmulation.js

I have seen it sometime not hang, but then it doesn't seem, to run any test.

Expected behaviour

Test go through.

Diagnostic

It seems to go on a loop where applyElemHideEmulation() gets called infinitely, because loading script for ElemHideEmulation seems to fail.

If I revert to revision c7ae7532578a, the test fail differently, with

Test failed: global failure: 
Failed assertion: SyntaxError: Expected an identifier but found 'rules' instead
  file:////home/hub/source/eyeo/adblockpluscore/chrome/content/elemHideEmulation.js:86

Test failed: Element hiding emulation: Verbatim property selector: 
Failed assertion: Died on test #1 global code@file:////home/hub/source/eyeo/adblockpluscore/test/browser/elemHideEmulation.js:123:11: Can't find variable: ElemHideEmulation
  applyElemHideEmulation@file:////home/hub/source/eyeo/adblockpluscore/test/browser/elemHideEmulation.js:96:48
  file:////home/hub/source/eyeo/adblockpluscore/test/browser/elemHideEmulation.js:129:27

I'll look at that as it should work. (with a fix)

Change History (6)

comment:1 Changed 2 years ago by hfiguiere

Revision 2fc6eeda3478 is causing the breakage as it uses syntax that does not go through with the tests... (let, for..in)

comment:2 Changed 2 years ago by hfiguiere

Revision c7ae7532578a cause another breakage by not updating the test after an API change.

comment:3 Changed 2 years ago by hfiguiere

  • Blocking 3143 added

comment:4 Changed 2 years ago by hfiguiere

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:5 Changed 2 years ago by abpbot

A commit referencing this issue has landed:
Issue 4962 - Fix the tests.

comment:6 Changed 2 years ago by hfiguiere

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.