Opened 6 months ago

Last modified 6 months ago

#4979 new change

Compile for 'armeabi'

Reported by: asmirnov Assignee:
Priority: P2 Milestone:
Module: Libadblockplus-Android Keywords:
Cc: sergz Blocked By:
Blocking: Platform: Android
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by asmirnov)

Background

We were asked by some of our partners for provide 'armeabi' version of the library instead of 'armeabi-v7a' for compatibility reason. I'd like to add (not replace) 'armeabi' ABI for the library as 'armeabi-v7a' can be filtered out from the final apk with the following build.gradle config even if aar has 'armeabi-v7a' files:

    android{
      defaultConfig{
         ndk {
            abiFilters 'armeabi', 'x86'
         }
      }

I believe the aar should contain as much as possible of supported ABIs.

What to change

Edit build.gradle file (and probably Ant/Maven build configs). Also libadblockplus should be modified to be able to build 'armeabi' artifact too (not 'armeabi-v7a' and 'x86' only) - @Sergei, please link to your ticket as blocking.

Change History (1)

comment:1 Changed 6 months ago by asmirnov

  • Cc sergz added
  • Description modified (diff)
Note: See TracTickets for help on using tickets.