Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#497 closed defect (incomplete)

Can't make filter preferences short enough to fit in available space

Reported by: Will Pittenger Assignee:
Priority: Unknown Milestone:
Module: User-Interface Keywords:
Cc: smultron45@…, greiner Blocked By:
Blocking: Platform:
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

Pale Moon 24.4.5 64-bit on Windows 7 64-bit SP1.
ABP 2.6

How to reproduce

  1. Open the filter preferences window where you don't have much room. (My test had less than shown in the link below.)
  2. Does it fit?

Observed behaviour

See https://adblockplus.org/forum/viewtopic.php?f=1&t=23154

Expected behaviour

Window should be resizable to fit in relatively small spaces

Attachments (4)

palemoon_filter-prefs.png (86.1 KB) - added by philll 5 years ago.
can't resize window.png (84.3 KB) - added by Will Pittenger 5 years ago.
This is the window I'm trying to make smaller
497_about-support (10.0 KB) - added by philll 5 years ago.
CABP settings.png (421.4 KB) - added by Will Pittenger 5 years ago.
My CABP settings

Download all attachments as: .zip

Change History (25)

comment:1 Changed 5 years ago by mapx

  • Cc smultron45@… added

comment:2 Changed 5 years ago by philll

  • Resolution set to invalid
  • Status changed from new to closed

Apparently, I don't exactly know, what your issue is about. As you can see in attachment:palemoon_filter-prefs.png, I can have the filter preferences windows pretty small while still displaying the find bar. Feel free to reopen this issue after having added more details.

Changed 5 years ago by philll

comment:3 Changed 5 years ago by Will Pittenger

Well, I guess you want about:support.

Application Basics


Name: Pale Moon
Version: 24.5.0
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:24.0) Gecko/20140419 Firefox/24.0 PaleMoon/24.5.0

Extensions


Name: Adblock Plus
Version: 2.6
Enabled: true
ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: Add to Search Bar
Version: 2.0
Enabled: true
ID: add-to-searchbox@…

Name: Back/forward dropmarker
Version: 1.0
Enabled: true
ID: {d618933b-9eb4-1c04-949d-0f9b1a39ebb9}

Name: Better Gmail 2
Version: 1.2
Enabled: true
ID: bettergmail2@…

Name: BugzillaJS
Version: 3.2.1
Enabled: true
ID: jid0-NgMDcEu2B88AbzZ6ulHodW9sJzA@jetpack

Name: CoLT
Version: 2.6.4
Enabled: true
ID: {e6c4c3ef-3d4d-42d6-8283-8da73c53a283}

Name: Config Descriptions
Version: 1.0
Enabled: true
ID: {1823e248-6bf4-f6f1-7901-65a68e8b6c1e}

Name: Configuration Mania
Version: 1.19.2014050501
Enabled: true
ID: {c4d362ec-1cff-4ca0-9031-99a8fad7995a}

Name: Cookie Monster
Version: 1.2.0
Enabled: true
ID: {45d8ff86-d909-11db-9705-005056c00008}

Name: Copy goo.gl URL
Version: 1.1
Enabled: true
ID: jid0-Mw0dfl2BI1XYuyZgtIAytUencu4@jetpack

Name: Copy Link URL
Version: 1.5
Enabled: true
ID: copylinkurl@…

Name: Customizations for Adblock Plus
Version: 1.0.4a.77
Enabled: true
ID: customization@…

Name: CuteButtons - Crystal SVG
Version: 0.3.6
Enabled: true
ID: CuteButtonsCrystalSVG@ChoGGi

Name: Element Hiding Helper for Adblock Plus
Version: 1.3
Enabled: true
ID: elemhidehelper@…

Name: ErrorZilla Plus
Version: 1.2.3
Enabled: true
ID: {03651b2d-eb7d-4be7-af1b-dc0cd162dd54}

Name: Extended Statusbar
Version: 1.5.8
Enabled: true
ID: {daf44bf7-a45e-4450-979c-91cf07434c3d}

Name: Extension Options Menu
Version: 2.8
Enabled: true
ID: {1feca320-6b4d-11df-a08a-0800200c9a66}

Name: Firebug
Version: 1.12.8
Enabled: true
ID: firebug@…

Name: FireFTP
Version: 2.0.18
Enabled: true
ID: {a7c6cf7f-112c-4500-a7ea-39801a327e5f}

Name: FireShot
Version: 0.98.54
Enabled: true
ID: {0b457cAA-602d-484a-8fe7-c1d894a011ba}

Name: Flagfox
Version: 5.0.3
Enabled: true
ID: {1018e4d6-728f-4b20-ad56-37578a4de76b}

Name: FlashGot
Version: 1.5.5.98
Enabled: true
ID: {19503e42-ca3c-4c27-b1e2-9cdb2170ee34}

Name: GlassMyFox
Version: 1.3.4
Enabled: true
ID: GlassMyFox@ArisT2_Noia4dev

Name: Google Shortcuts
Version: 2.1.7.1
Enabled: true
ID: {5C46D283-ABDE-4dce-B83C-08881401921C}

Name: gTranslate
Version: 0.9
Enabled: true
ID: {aff87fa2-a58e-4edd-b852-0a20203c1e17}

Name: gui:config
Version: 1.2.3
Enabled: true
ID: guiconfig@…

Name: IE Tab 2 (FF 3.6+)
Version: 5.12.12.1
Enabled: true
ID: {1BC9BA34-1EED-42ca-A505-6D2F1A935BBB}

Name: InFormEnter
Version: 0.76
Enabled: true
ID: {5546F97E-11A5-46b0-9082-32AD74AAA920}

Name: Link Alert
Version: 1.0.2
Enabled: true
ID: linkalert.conlan@…

Name: Locationbar²
Version: 1.0.6
Enabled: true
ID: locationbar2@…

Name: More Tools Menu
Version: 1.2.4
Enabled: true
ID: {9a7a67d3-3048-47fb-acde-d0f7ae51f86a}

Name: Navigational Sounds
Version: 1.2.4
Enabled: true
ID: {d84a846d-f7cb-4187-a408-b171020e8940}

Name: Nightly Tester Tools
Version: 3.7
Enabled: true
ID: {8620c15f-30dc-4dba-a131-7c5d20cf4a29}

Name: NoScript
Version: 2.6.8.24
Enabled: true
ID: {73a6fe31-595d-460b-a920-fcc0f8843232}

Name: Organize Search Engines
Version: 1.7
Enabled: true
ID: organize-search-engines@…

Name: Pale Moon Commander
Version: 1.3.6
Enabled: true
ID: commander@…

Name: Pastebin
Version: 3.0
Enabled: true
ID: pastebin.com@…

Name: Print / Print Preview (Update)
Version: 0.7.7
Enabled: true
ID: printprintpreview-andrewsfirefoxextensions@…

Name: Restartless Restart
Version: 9
Enabled: true
ID: restartless.restart@…

Name: Scriptish
Version: 0.1.11
Enabled: true
ID: scriptish@…

Name: Searchbar Autosizer
Version: 3.0.1
Enabled: true
ID: {655397ca-4766-496b-b7a8-3a5b176ee4c2}

Name: SearchBox Sync
Version: 1.4.0
Enabled: true
ID: {65d1639c-419f-4b52-9520-2d1455e5091b}

Name: SearchWP
Version: 2.6.3
Enabled: true
ID: {3e270ac3-8936-43fb-ad20-b4685172a83d}

Name: Session Manager
Version: 0.8.1.1
Enabled: true
ID: {1280606b-2510-4fe0-97ef-9b5a22eafe30}

Name: Show Anchors 4
Version: 2.3.4
Enabled: true
ID: show_anchors_4@…

Name: Stylish
Version: 1.4.3
Enabled: true
ID: {46551EC9-40F0-4e47-8E18-8E5CF550CFB8}

Name: Tab Groups
Version: 0.2
Enabled: true
ID: firefox-tabgroups@…

Name: Tab Mix Plus
Version: 0.4.1.3.1
Enabled: true
ID: {dc572301-7619-498c-a57d-39143191b318}

Name: TabGroups Menu
Version: 0.9.1
Enabled: true
ID: tabgroupsmenu@…

Name: TargetKiller
Version: 0.8
Enabled: true
ID: {9a4cea50-3bc5-47e5-aec8-5eda9d4839d6}

Name: TinyURL Generator
Version: 2.6.1
Enabled: true
ID: tinyurl.addon@…

Name: Toolbar Buttons
Version: 1.0
Enabled: true
ID: {03B08592-E5B4-45ff-A0BE-C1D975458688}

Name: View Cookies
Version: 1.12
Enabled: true
ID: {8F6A6FD9-0619-459f-B9D0-81DE065D4E21}

Name: View Dependencies
Version: 0.3.3.2
Enabled: true
ID: {8965bb4b-c2ca-2b84-6b49-7afb2760518c}

Name: View Frames
Version: 1.0
Enabled: true
ID: viewframes@…

Name: Zoom Page
Version: 10.2
Enabled: true
ID: zoompage@DW-dev

Name: Add-on Compatibility Reporter
Version: 2.0.3
Enabled: false
ID: compatibility@…

Name: All-in-One Sidebar
Version: 0.7.21
Enabled: false
ID: {097d3191-e6fa-4728-9826-b533d755359d}

Name: Hide Caption Titlebar Plus
Version: 2.8.2
Enabled: false
ID: hidecaptionplus-dp@…

Name: HP Detect
Version: 1.0.27.1
Enabled: false
ID: {ab91efd4-6975-4081-8552-1b3922ed79e2}

Name: OneClick YouTube Downloader
Version: 1.0.8
Enabled: false
ID: {35379F86-8CCB-4724-AE33-4278DE266C70}

Name: Redirect Remover
Version: 2.6.4
Enabled: false
ID: {fe0258ab-4f74-43a1-8781-bcdf340f9ee9}

Name: Stylish-Custom
Version: 0.7.7
Enabled: false
ID: Stylish-Custom@…

Name: User Style Manager
Version: 1.0
Enabled: false
ID: UserStyleManager@girishsharma

Name: XFINITY Constant Guard Protection Suite
Version: 1.13.1031.1
Enabled: false
ID: idvaultaddin@whitesky

Important Modified Preferences


accessibility.blockautorefresh: true
accessibility.typeaheadfind: true
accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 1048576
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.disk.smart_size_cached_value: 358400
browser.display.standalone_images.background_color: #FFF
browser.places.smartBookmarksVersion: 4
browser.search.openintab: true
browser.search.useDBForOrder: true
browser.sessionstore.max_tabs_undo: 30
browser.sessionstore.max_windows_undo: 10
browser.sessionstore.restore_hidden_tabs: true
browser.sessionstore.upgradeBackup.latestBuildID: 20140212131424
browser.startup.homepage: https://news.google.com
browser.startup.homepage_override.buildID: 20140419190604
browser.startup.homepage_override.mstone: 24.5.0
browser.tabs.tabMaxWidth: 350
browser.tabs.warnOnClose: false
browser.urlbar.default.behavior: 24
browser.urlbar.doubleClickSelectsAll: true
browser.urlbar.maxRichResults: 30
browser.urlbar.mouseOnBottomLinkifies: true
dom.battery.enabled: false
dom.disable_window_open_feature.close: true
dom.disable_window_open_feature.menubar: true
dom.disable_window_open_feature.scrollbars: true
dom.disable_window_open_feature.toolbar: true
dom.event.clipboardevents.enabled: false
dom.ipc.plugins.enabled.npietab2.dll: true
dom.max_chrome_script_run_time: 40
dom.max_script_run_time: 40
dom.mozApps.used: true
dom.mozApps.whitelist: https://myapps.mozillalabs.com/
dom.report_all_js_exceptions: true
dom.vibrator.enabled: false
dom.w3c_touch_events.expose: false
extensions.lastAppVersion: 24.5.0
font.internaluseonly.changed: false
font.minimum-size.x-western: 12
font.size.fixed.x-western: 14
font.size.variable.x-western: 14
gfx.direct3d.last_used_feature_level_idx: 0
gfx.direct3d.prefer_10_1: true
gfx.font_rendering.cleartype.always_use_for_content: true
gfx.font_rendering.directwrite.enabled: true
html5.enable: true
javascript.options.strict: true
keyword.enabled: false
media.directshow.enabled: true
mousewheel.min_line_scroll_amount: 3
mousewheel.withaltkey.action: 1
mousewheel.withcontrolkey.action: 3
mousewheel.withnokey.numlines: 3
mousewheel.withshiftkey.numlines: 1
network.cookie.cookieBehavior: 1
network.cookie.prefsMigrated: true
places.database.lastMaintenance: 1400039388
places.history.expiration.transient_current_max_pages: 104858
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
plugin.state.npunity3d: 2
plugin.state.npwlpg: 0
privacy.donottrackheader.enabled: true
privacy.sanitize.migrateFx3Prefs: true
security.ask_for_password: 1
security.password_lifetime: 120
security.warn_viewing_mixed: false
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1398528872
webgl.enabled_for_all_sites: true
webgl.msaa-force: true
webgl.prefer-native-gl: true

Graphics


Adapter Description: AMD Radeon HD 7570
Adapter Drivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM: 2048
Device ID: 0x675d
Direct2D Enabled: true
DirectWrite Enabled: true (6.2.9200.16571)
Driver Date: 4-25-2012
Driver Version: 8.960.11.1000
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 10
Vendor ID: 0x1002
windowLayerManagerRemote: false
AzureCanvasBackend: direct2d
AzureContentBackend: direct2d
AzureFallbackCanvasBackend: cairo

JavaScript


Incremental GC: true

Accessibility


Activated: false
Prevent Accessibility: 1

Library Versions


NSPR
Expected minimum version: 4.10.2
Version in use: 4.10.2

NSS
Expected minimum version: 3.15.4 Basic ECC
Version in use: 3.15.4 Basic ECC

NSSSMIME
Expected minimum version: 3.15.4 Basic ECC
Version in use: 3.15.4 Basic ECC

NSSSSL
Expected minimum version: 3.15.4 Basic ECC
Version in use: 3.15.4 Basic ECC

NSSUTIL
Expected minimum version: 3.15.4
Version in use: 3.15.4

Version 0, edited 5 years ago by Will Pittenger (next)

comment:4 Changed 5 years ago by philll

Well, actually, I was more looking for something like a description with maybe a screenshot of what your problem is about, as I did not understand it.

comment:5 Changed 5 years ago by Will Pittenger

I don't know how a screenshot would help. And I'm trying to explain it as best I can.

comment:6 Changed 5 years ago by Will Pittenger

So is there a way to reset the preference for that window's size? Or, for that matter, manually change it?

Changed 5 years ago by Will Pittenger

This is the window I'm trying to make smaller

Changed 5 years ago by philll

comment:7 Changed 5 years ago by greiner

  • Cc greiner added

Please note that this is not intended behavior. It seems like there's something wrong with the styles but I couldn't reproduce it with Pale Moon 24 on Windows 8.1.

comment:8 Changed 5 years ago by philll

You could try to use a new, clean profile, maybe something's corrupted there leading to that behaviour. It should in the end look like the screenshot that I have added.

comment:9 Changed 5 years ago by Will Pittenger

Could this be an issue to to my use of a 64-bit browser?

comment:10 Changed 5 years ago by greiner

No, I can't imagine this to be the case. Have you tried out any of the following actions?

  • reinstall Adblock Plus
  • reinstall Pale Moon
  • create a new clean profile (as philll already mentioned)

comment:11 Changed 5 years ago by Will Pittenger

Just thought of something. I was using the dev version of ABP. But then I decided to switch in order to have fewer updates. I don't suppose that could be it.

comment:12 Changed 5 years ago by Will Pittenger

Well, I did get a smaller window, but I don't see how that fixes anything. PM seems to be missing the reset profile feature in stock Firefox.

BTW: This clearly is something that belongs in the forums. I would have left it there, but I was told to file a bug. Shortly after I did, that thread was locked. So I can't take the case back there. :(

comment:13 Changed 5 years ago by Will Pittenger

Ok. Found the reset stuff. But it resets more than just ABP. All extension preferences would be removed.

comment:14 Changed 5 years ago by mapx

unblocked ... but you should continue here

comment:15 Changed 5 years ago by Will Pittenger

Looks like Customizations for ABP was the problem. I don't know why, but the problem vanished with CABP disabled. Reenable it and the problem is back. I tried CABP 1.0.3 as well. Still there.

comment:16 Changed 5 years ago by philll

Okay, I now also added CABP and checked the vertical layout option, but still did not face the broken styles. Please try to re-install CABP. If the behaviour then still exists, please tell us all your settings in CABP.

Changed 5 years ago by Will Pittenger

My CABP settings

comment:17 Changed 5 years ago by Will Pittenger

There you go.

comment:18 follow-up: Changed 5 years ago by greiner

Still no success. Does it still look like that after you disable Customizations for Adblock Plus?

comment:19 Changed 5 years ago by philll

@greiner: as he said: "Looks like Customizations for ABP was the problem. I don't know why, but the problem vanished with CABP disabled."

comment:20 Changed 5 years ago by greiner

Sorry, must have missed that. In that case I'd agree with considering it invalid since we are unable to reproduce it.

comment:21 in reply to: ↑ 18 Changed 5 years ago by Will Pittenger

Replying to greiner:

Still no success. Does it still look like that after you disable Customizations for Adblock Plus?

@greiner: Look like what?

Note: See TracTickets for help on using tickets.