Opened 6 years ago

Closed 6 years ago

#498 closed defect (fixed)

ABP 1.8.1 + chrome 33 - tab key crashes some pages

Reported by: mapx Assignee: sebastian
Priority: P2 Milestone: Adblock-Plus-1.8.3-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: greiner, philll Blocked By:
Blocking: Platform:
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/6238490647855104

Description

Environment

chrome 33.0.1750.152
ABP 1.8.1
easylist

How to reproduce

go to facebook.com or any wikipedia article
press TAB key
the page crashes

2 reports on the forum:
https://adblockplus.org/forum/viewtopic.php?f=10&t=23134
https://adblockplus.org/forum/viewtopic.php?f=11&t=23158

I suggested the upgrade to chrome 34 or 35 ==> no any issues

Change History (8)

comment:1 Changed 6 years ago by sebastian

Does it still happen with the devbuild?

Last edited 6 years ago by sebastian (previous) (diff)

comment:2 Changed 6 years ago by mapx

I personally don't know, I just brought here the reports

comment:3 Changed 6 years ago by philll

As long as no third party browser bases its version on Chrome 33 and also includes the bug, should we do anything about it? I couldn't reproduce this so far with any of my Chrome 34/35 instances.

comment:4 Changed 6 years ago by sebastian

  • Cc philll added; sebastian removed
  • Owner set to sebastian

I tested some older Chrome versions. And this happens in Chrome 31 to 33, when using Shadow DOM.

The best we can do here is not using Shadow DOM in those versions of Chrome. Note that this will bring back #309 to users of Chrome 31 and 33. However that issue is way less significant than this issue. Also note that we already stopped using Shadow DOM on Chrome 32 to work around an other issue.

Last edited 6 years ago by sebastian (previous) (diff)

comment:5 Changed 6 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:6 Changed 6 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next

comment:7 Changed 6 years ago by sebastian

  • Ready set

comment:8 Changed 6 years ago by sebastian

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.