Opened 3 years ago

Closed 3 years ago

#4987 closed defect (rejected)

Custom filters list has no horizontal scrollbar in Safari or FF WebEx

Reported by: Ross Assignee: wspee
Priority: P2 Milestone:
Module: Platform Keywords:
Cc: kzar, sebastian, trev, wspee Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

ABP 1.12.4.1739
Safari 10 / OS X 10.12
Firefox 52 / Windows 10

How to reproduce

  1. Open [ABP Options] > [Custom filters] tab.
  2. Enter a string of text longer than the text field.
  3. Select [Add].

Observed behaviour

#1121 added a scrollbar to the list box displaying the filters. However it does not appear in Safari or FF WebEx build.

Expected behaviour

To be able to scroll the list of filters horizontally like in Chrome/Opera (if possible).

Change History (5)

comment:1 Changed 3 years ago by kzar

  • Cc kzar sebastian trev added
  • Component changed from Unknown to Platform
  • Platform changed from Safari to Unknown / Cross platform
  • Priority changed from P3 to Unknown

comment:2 Changed 3 years ago by kzar

  • Cc wspee added
  • Priority changed from Unknown to P2
  • Ready set

I can reproduce this the webext extension and Firefox 52. Didn't try with Safari but can believe the problem exists there too. Looks like the overflow: auto style might not have been enough Winsley?

comment:3 Changed 3 years ago by wspee

  • Owner set to wspee

comment:4 Changed 3 years ago by wspee

This is because ff/safari seem to ignore overflow:auto on select inputs (makes sense for normal selects I guess).

A possible workarround would be to embed the select in a container and let the container overflow-x but then the vertical scrollbars would only be visible if you scroll to the right.

https://wvspee.github.io/snippets/4987_overflow_auto_firefox.html

But this would be a degradation on chrome I guess?

In light of the new options page, this not beeing worse than before and not the most important bug I'm not sure if we would want to fix this?!

comment:5 Changed 3 years ago by sebastian

  • Resolution set to rejected
  • Status changed from new to closed

IMO, this workaround doesn't even improve the usability on Firefox/Safari, but merely trades in one usability issue (i.e. lack of vertical scrolling) for another one (i.e. having to scroll vertically to use the horizontal scrollbar). The only solution seems to be not using a standard <select> element, but a custom UI, which doesn't make much sense to design/implement still for the old options page.

Also note that after we released Adblock Plus 1.12.4, we moved Safari support into a branch with low maintenance. So #1121 didn't even land in the devbuilds for Safari, neither did we had a release for Safari since then. Also keep in mind that the whole point of this move was to no longer have to target Safari when developing for the our more advanced platforms. So Safari can be ignored, anyway.

Note: See TracTickets for help on using tickets.