Opened 3 years ago

Closed 3 years ago

#4990 closed change (duplicate)

[CMS] Add Pytest Coverage Report To Tox

Reported by: jsonesen Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: trev, kvas, fhd, sebastian Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Background

Last week we had a situation arise due to some cosmetic changes that lead to accidental logic regressions being introduced. The changes were reviewed and yet the regressions slipped through. A large reason for this was that we believed this code was covered under the existing tests which we now know to be false. Our confusion could have been avoided by having coverage reports.

What to change

Configure the tox.ini to utilize coverage reports in the cms module.

Change History (3)

comment:1 Changed 3 years ago by kvas

This seems to be a duplicate of #4981 :)

comment:2 Changed 3 years ago by jsonesen

whooops

comment:3 Changed 3 years ago by jsonesen

  • Resolution set to duplicate
  • Status changed from new to closed

whooops

Note: See TracTickets for help on using tickets.