Opened 6 weeks ago

Closed 6 weeks ago

Last modified 6 weeks ago

#5009 closed defect (fixed)

Popup blocking false positives in Adblock Plus for Chrome

Reported by: kzar Assignee: kzar
Priority: P1 Milestone: Adblock-Plus-1.13.1-for-Chrome-Opera
Module: Platform Keywords:
Cc: mapx, trev, sebastian, SMed79, fanboy, arthur, rraceanu, Ross, scheer, philll Blocked By:
Blocking: Platform: Chrome
Ready: yes Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29386580/

Description (last modified by kzar)

Environment

Adblock Plus 1.13
Chrome 56
EasyList + AA subscriptions, no custom filters.

How to reproduce

  1. Open the developer tools, switch to the Adblock Plus pane.
  2. Middle click on this link, so that it opens in a new tab: http://www.winfuture.de

Observed behaviour

The tab is closed by Adblock Plus. Blocked by the filter ||googleads.g.doubleclick.net^$popup,third-party

Adblock Plus lists four POPUP requests:

  1. http://www.winfuture.de/
  2. http://winfuture.de/
  3. about:blank
  4. https://googleads.g.doubleclick.net/pagead/html/r20170313/r20170110/zrt_lookup.html

The first two are to be expected, since redirections that happen before a popup has finished loading are also considered as popups by Adblock Plus. The second too look like they are in error, possibly for a frame inside the page.

Expected behaviour

The tab shouldn't be closed.

Notes

See the following discussions:

This seems to be a regression caused by Issue 4834 - Block redirected popups.

Hints for testers

  1. Ensure the bug where popups are blocked by the wrong rule no longer happens.
  2. Ensure that popup blocking otherwise works as before, we should be blocking all the same popups as before.

Note: Chrome considers links opened in a new tab by middle-click to be the same as popup windows. So that is a good way to test the popup blocking logic works properly, without creating test pages.

Change History (11)

comment:1 Changed 6 weeks ago by kzar

  • Platform changed from Unknown / Cross platform to Chrome

comment:2 Changed 6 weeks ago by kzar

  • Description modified (diff)

Seems like a regression caused by #4834, which apparently didn't get tested by QA.

comment:3 Changed 6 weeks ago by mapx

  • Cc SMed79 fanboy arthur added

comment:4 Changed 6 weeks ago by kzar

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

Seems like there was a pre-existing bug whereby we never actually checked if the redirection inside a popup was for the top-level frame. Now that we're watching for redirections more eagerly using onBeforeRequest it became a problem.

Last edited 6 weeks ago by kzar (previous) (diff)

comment:5 Changed 6 weeks ago by kzar

  • Description modified (diff)

comment:6 Changed 6 weeks ago by abpbot

A commit referencing this issue has landed:
Issue 5009 - Ignore frame redirections within popups

comment:7 Changed 6 weeks ago by kzar

  • Milestone set to Adblock-Plus-for-Chrome-Opera-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:8 Changed 6 weeks ago by kzar

We are considering putting an emergency release out for this fix. If anyone can confirm the fix works for them with the latest devbuild Adblock Plus for Google Chrome and Opera 1.13.0.1745 it would be much appreciated.

Last edited 6 weeks ago by kzar (previous) (diff)

comment:9 Changed 6 weeks ago by kzar

  • Cc rraceanu Ross scheer philll added
  • Description modified (diff)

Added hints for testers section, hoping someone from QA is around to help test this.

comment:10 Changed 6 weeks ago by scheer

  • Tester changed from Unknown to Scheer
  • Verified working set
  • The example given above no longer occurs with http://www.winfuture.de/. I tried this with a currently open session on ABP 1.13 vs 1.13.0.1745. The links that were opened on 1.13 and closed, opened correctly on 1.13.0.1745.
  • All other pop-up logic as far as I could see remains unaffected.

ABP 1.13.0.1745
Chrome 56
Windows 7 64 Bit

comment:11 Changed 6 weeks ago by rhana@…

Hey guys,

Would this bug cause a referred link to a whitelisted site to try to open in a new tab, then immediately close? Or is that something different? Reported to us through Twitter, happening only in ABP.

To reproduce:

  1. In ABP latest stable release, visit this page: https://www.facebook.com/jules.r.clarke/posts/973876849357159
  2. Click the link. It should open a blog page (http://virtualgherkin.blogspot.co.uk/2016/03/disability-cuts-and-life-chances.html).
  3. Whitelist that site and close the tab.
  4. Return to the Facebook post in Step 1 and click the blog link again. The tab opens, then closes after a second or two.

This doesn't happen in AdBlock 3.8.8. I haven't checked other browsers, just Chrome.

Note: See TracTickets for help on using tickets.