Opened 10 months ago

Closed 10 months ago

Last modified 10 months ago

#5029 closed defect (fixed)

Settings menu item hidden on iOS 8.4

Reported by: mario Assignee:
Priority: P2 Milestone: Adblock-Browser-for-iOS-1.5.2
Module: Adblock-Browser-for-iOS Keywords:
Cc: tomasnovella, jand, shikitita Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: yes Confidential: no
Tester: Unknown Verified working: yes
Review URL(s):

Description (last modified by mario)

Environment

iPhone 6s
iOS 8.4

How to reproduce

  1. Install ABB
  2. Run ABB
  3. Click through onboarding slides
  4. Make sure no website is opened and you're on the dashboard
  5. Click the ABB icon at the bottom menu

OR

  1. Install ABB
  2. Run ABB
  3. Click through onboarding slides
  4. Visit google.com
  5. Open a new tab (and leave it empty)
  6. Click the ABB icon at the bottom menu

Observed behaviour

The "Settings" menu item is not displayed as shown in this screenshot.

Expected behaviour

The "Settings" menu item is displayed.

Attachments (1)

Screen Shot 2017-03-22 at 17.22.39.png (40.0 KB) - added by mario 10 months ago.

Download all attachments as: .zip

Change History (7)

Changed 10 months ago by mario

comment:1 Changed 10 months ago by mario

  • Cc tomasnovella jand shikitita added
  • Description modified (diff)

comment:2 Changed 10 months ago by jand

  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 10 months ago by mario

  • Milestone set to Adblock-Browser-for-iOS-1.5.2
  • Ready set

comment:4 Changed 10 months ago by mario

  • Description modified (diff)
  • Resolution fixed deleted
  • Status changed from closed to reopened

The way of reproduction in the description is fixed. However, the issue is still reproducible in another way:

  1. Install ABB
  2. Run ABB
  3. Click through onboarding slides
  4. Visit google.com
  5. Open a new tab (and leave it empty)
  6. Click the ABB icon at the bottom menu

Result: The "Settings" menu item is not displayed as shown in this screenshot.
Expected: The "Settings" menu item is displayed.

comment:5 Changed 10 months ago by jand

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:6 Changed 10 months ago by mario

  • Verified working set

As we're limited to perform regression testing on iOS 8.4, I've chimed in and conducted the tests for this one. Both aforementioned reproduction scenarios work fine. Both result in the expected behavior.

Note: See TracTickets for help on using tickets.