Opened 3 years ago

Closed 3 years ago

#5047 closed defect (duplicate)

build libadblockplus-android error

Reported by: geelong Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: Blocked By:
Blocking: Platform: Android
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

mac

How to reproduce

  1. check out libadblockplus-android
  2. ./ensure_dependencies.py
  3. ./gradlew assembleDebug

...

Observed behaviour

[x86] Compile++ : adblockplus-jni <= JniLibrary.cpp

[x86] Compile++ : adblockplus-jni <= JniJsEngine.cpp
[x86] Compile++ : adblockplus-jni <= JniFilterEngine.cpp
In file included from jni/libadblockplus-binaries/include/AdblockPlus.h:38:0,

from /Users/geelong/developer/workspace_3rd/libadblockplus-android2/libadblockplus-android/jni/JniFilterEngine.cpp:18:

jni/libadblockplus-binaries/include/AdblockPlus/FilterEngine.h: In function 'jlong JniCtor(JNIEnv*, jclass, jlong)':
jni/libadblockplus-binaries/include/AdblockPlus/FilterEngine.h:501:14: error: 'AdblockPlus::FilterEngine::FilterEngine(const JsEnginePtr&)' is private

explicit FilterEngine(const JsEnginePtr& jsEngine);


/Users/geelong/developer/workspace_3rd/libadblockplus-android2/libadblockplus-android/jni/JniFilterEngine.cpp:52:63: error: within this context

return JniPtrToLong(new AdblockPlus::FilterEngine(jsEngine));


make: * Users/geelong/developer/workspace_3rd/libadblockplus-android2/libadblockplus-android/build/intermediates/ndkBuild/debug/obj/local/x86/objs-debug/adblockplus-jni/JniFilterEngine.o Error 1

  • Try:

Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

Expected behaviour

build success

Change History (3)

comment:1 Changed 3 years ago by geelong

please close me . because i update libadblockplus-binaries, it is not match the jni

comment:2 Changed 3 years ago by asmirnov

A duplicate of #5054

comment:3 Changed 3 years ago by asmirnov

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.