Opened 2 years ago

Closed 2 years ago

Last modified 4 months ago

#5054 closed defect (duplicate)

build libadblockplus-android with error ndk

Reported by: geelong Assignee:
Priority: P5 Milestone:
Module: Libadblockplus-Android Keywords:
Cc: Blocked By:
Blocking: Platform: Android
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

mac

How to reproduce

  1. i set ndk.dir=/Users/geelong/developer/android-ndk-r10c in local.properties
  2. when i build with ./gradlew assembleDebug, it use the wrong ndk /home/antoine/android-ndk-r10c/sources/

...

Observed behaviour

:init(void*)'

/home/antoine/android-ndk-r10c/sources/cxx-stl/llvm-libc++/libcxx/include/streambuf:371: error: undefined reference to 'std::1::locale::locale()'
./../src/JsError.cpp:23: error: undefined reference to 'std::runtime_error::runtime_error(std::
1::basic_string<char, std::1::char_traits<char>, std::1::allocator<char> > const&)'
/home/antoine/android-ndk-r10c/sources/cxx-stl/llvm-libc++/libcxx/include/ostream:479: error: undefined reference to 'std::1::ios_base::getloc() const'
/home/antoine/android-ndk-r10c/sources/cxx-stl/llvm-libc++/libcxx/include/ostream:490: error: undefined reference to 'std::
1::ios_base::set_badbit_and_consider_rethrow()'
/home/antoine/android-ndk-r10c/sources/cxx-stl/llvm-libc++/libcxx/include/ostream:494: error: undefined reference to 'std::
1::num_put<char, std::1::ostreambuf_iterator<char, std::1::char_traits<char> > >::id'
/home/antoine/android-ndk-r10c/sources/cxx-stl/llvm-libc++/libcxx/include/ostream:494: error: undefined reference to 'std::1::ctype<char>::id'
/home/antoine/android-ndk-r10c/sources/cxx-stl/llvm-libc++/libcxx/include/sstream:894: error: undefined reference to 'std::
1::ios_base::init(void*)'
/home/antoine/android-ndk-r10c/sources/cxx-stl/llvm-libc++/libcxx/include/streambuf:371: error: undefined reference to 'std::1::locale::locale()'
/home/antoine/android-ndk-r10c/sources/cxx-stl/llvm-libc++/libcxx/include/ostream:367: error: undefined reference to 'std::
1::ios_base::set_failbit_and_consider_rethrow()'
/home/antoine/android-ndk-r10c/sources/cxx-stl/llvm-libc++/libcxx/include/streambuf:371: error: undefined reference to 'std::
1::locale::locale()'
../third_party/v8/include/v8.h:3997: error: undefined reference to 'std::1::ctype<char>::id'
/Users/geelong/developer/workspace_3rd/libadblockplus-android2/libadblockplus-android/jni/./libadblockplus-binaries/android_armeabi-v7a/libv8_base.a(platform-posix.o):platform-posix.cc:function v8::internal::OS::CommitPageSize(): error: undefined reference to '
page_size'
/Users/geelong/developer/workspace_3rd/libadblockplus-android2/libadblockplus-android/jni/./libadblockplus-binaries/android_armeabi-v7a/libv8_base.a(platform-posix.o):platform-posix.cc:function v8::internal::OS::AllocateAlignment(): error: undefined reference to 'page_size'
collect2: error: ld returned 1 exit status
make: * Users/geelong/developer/workspace_3rd/libadblockplus-android2/libadblockplus-android/build/intermediates/ndkBuild/release/obj/local/armeabi-v7a/libadblockplus-jni.so Error 1

  • Try:

Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

Expected behaviour

build success

Change History (5)

comment:1 Changed 2 years ago by asmirnov

  • Component changed from Unknown to Libadblockplus-Android
  • Priority changed from Unknown to P5

comment:2 Changed 2 years ago by asmirnov

Duplicate of #4453

comment:3 Changed 2 years ago by asmirnov

Please use Android Ndk r10c for now.
You can find the direct links to downloading here:
https://hg.adblockplus.org/libadblockplus/file/tip/README.md#l33

comment:4 Changed 2 years ago by asmirnov

  • Resolution set to duplicate
  • Status changed from new to closed

comment:5 Changed 4 months ago by takken3

Just click here this site and learn more about how to defrag windows 10,this is right place and get the all possible solution https://windowsclassroom.com/defrag-windows-10 window are come with the many new features.

Note: See TracTickets for help on using tickets.