Opened 23 months ago

Last modified 21 months ago

#5076 new defect

Ver.1.13.2 crashes/autodisables with Opera 36.0

Reported by: yun Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: jsonesen, sebastian, mapx, Ross, kzar Blocked By:
Blocking: Platform: Opera
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Windows XP, Opera 36.0 (the last XP-compatible)
Adblock Plus 1.13.2 (Opera updates to it automatically, and it cannot be avoided; ver. 1.13 worked OK)
EasyList enabled

How to reproduce

After installing this version, Adblock automatically disables immediately or after some (usually short) time, even without loading any new page.

Observed behaviour

See above. Sometimes page crash happens. After enabling it, the same happens again. It may still appear as enabled in settings screen, but don't work (and the icon in top right browser corner disappears).
Restarting Opera does not help.

Expected behaviour

Normal working of course, like 1.13 and older versions! Or any way to block Opera from autoupdate to this version!

Change History (7)

comment:1 Changed 23 months ago by mapx

  • Cc jsonesen sebastian kvas mapx added

comment:2 Changed 23 months ago by sebastian

  • Cc Ross added; kvas removed

Removing kvas, he is not working on browser extensions.

Adding Ross. Ross, can you reproduce this? Also relevant to know:

  • Which (if any) newer Opera versions are effected too?
  • Are any versions of Chrome effected as well?
  • Can it only be reproduced on Windows XP, or also on other operating systems?
  • Can it also be reproduced with the development build?
Last edited 23 months ago by sebastian (previous) (diff)

comment:3 Changed 23 months ago by yun

Looks like in Chrome 49.0.2623.112 it works normal.
Not sure what "development build" is, but in Opera (and Chrome) I have "Developer mode active" in add-ons tab.
Cannot say anything about other browsers/OS versions.

comment:4 Changed 23 months ago by Ross

I could not reproduce this at all with about 20 minutes of browsing with both the current release and the latest dev build. The ABP icon is still present and functionality still works as expected.

yun, were there any specific steps or sites that triggers the problem more often? Do you have any other extensions installed?

ABP 1.13.2
ABP 1.13.2.1755
Opera 36 / Windows XP (x86)

comment:5 Changed 23 months ago by yun

Looks like it works now on my system, too. The only change was rebooting the system (the opened tabs are the same). But it happened several times (Opera updated the extension to 1.13.2 and it stopped working, I copied the old version (1.13) from backup and rebooted, 1.13 worked until updated again), so something is still wrong with 1.13.2 because it requires system reboot after updating which never happened with previous versions.

comment:6 Changed 22 months ago by yun

I encountered the problem again 3 times, both in Opera 36 and Chrome 49 (never in Firefox, probably because I have older version of Adblock there). I guess, the crash occurs after something is autoupdated - either Adblock by itself or its filters. After the crash happens, neither reloading Adblock nor the browser helps (Adblock works for about a minute and crashes again) - only rebooting the system helps, which is very annoying.

comment:7 Changed 21 months ago by kzar

  • Cc kzar added
  • Component changed from Unknown to Platform
Note: See TracTickets for help on using tickets.