Opened 3 years ago

Closed 2 years ago

#5089 closed change (duplicate)

Update the adblockpluscore dependency to 5079-export-elemhideemulation

Reported by: kzar Assignee:
Priority: P2 Milestone:
Module: Platform Keywords:
Cc: sebastian Blocked By: #5079
Blocking: #5080 Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by kzar)

Background

Once we've made the change in adblockpluscore to move elemHideEmulation.js and treat it at as a proper module, we'll need to update the adblockpluscore dependency of adblockpluschrome.

The other changes will be included:

What to change

  • Adjust the path of elemHideEmulation.js in the metadata. Ensure the module system is used.
  • Require the elemHideEmulation module for ElemHideEmulation and splitSelector now that they're no longer globals.
  • Remove the relevant /** global ... */ comments.

Hints for testers

  • Ensure that CSS property filters still work correctly.
  • Test that filters and subscriptions are still saved and loaded properly. The changes to filterStorage.js that are included shouldn't be relevant, but we should probably still check.

Change History (5)

comment:1 Changed 3 years ago by kzar

  • Owner kzar deleted

comment:2 Changed 3 years ago by kzar

  • Description modified (diff)

comment:3 Changed 2 years ago by jsonesen

  • Owner set to jsonesen

comment:4 Changed 2 years ago by kzar

  • Owner jsonesen deleted

(This is now a duplicate of #5584.)

comment:5 Changed 2 years ago by kzar

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.