Opened 15 months ago

Closed 15 months ago

Last modified 15 months ago

#5097 closed defect (fixed)

Element Hiding Helper: TypeError: node is undefined

Reported by: Ross Assignee: trev
Priority: P1 Milestone: Element-Hiding-Helper-1.4
Module: Extensions-for-Adblock-Plus Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29402624/

Description

Environment

ABP 2.8.2
EHH 1.3.10.551-beta
Firefox 52 / Windows 7
(Also occurs when using ABP 2.8.2.4242-beta)

How to reproduce

  1. Start EHH element selection.
  2. Hover an element (any).
  3. Press V to view source of element hovered.

Observed behaviour

The source is displayed as expected but the following error occurs:

TypeError: node is undefined commands.js:39:1

Expected behaviour

Error not to occur.

Change History (6)

comment:1 Changed 15 months ago by trev

Both this issue and #5099 are because both processes attempt to respond to the request - yet the selection is only running in one of them. I wonder why I don't see these errors but it is pretty obvious what the issue is and how to fix it.

comment:2 Changed 15 months ago by trev

  • Owner set to trev
  • Priority changed from P3 to P1
  • Ready set

comment:3 Changed 15 months ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:5 Changed 15 months ago by trev

  • Milestone set to Element-Hiding-Helper-1.4
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:6 Changed 15 months ago by Ross

  • Verified working set

Fixed. Errors no longer occur.

ABP 2.8.2
EHH 1.3.10.522-beta
Firefox 52 / Windows 7

Note: See TracTickets for help on using tickets.