Opened 3 years ago

Closed 2 years ago

#5120 closed change (fixed)

Make functions of WebRequest and FileSystem asynchrounous

Reported by: sergz Assignee:
Priority: P2 Milestone:
Module: Libadblockplus Keywords:
Cc: fhd Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Background

It would be useful for users and for our tests to provide users of libadblockplus with possibility to use their own scheduler for asynchronous operations. It's useful because, e.g. on MS Windows only one
worker thread is enough to support all our asynchronous operations. In tests we won't need to figure out how to deal with tasks running in different threads, we will be in control when a certain callback should be executed and the mocking implementation will be simpler (no more #4688 by design).

What to change

Methods of WebRequest and FileSystem should be asynchronous.

Additional notes

We should also take into account that it's a significant change of the interface of libadblockplus, therefore I think we should keep a possibility to use old interfaces for a while to give users a time to adjust their code. In order to do it we should create new interfaces for WebRequest and for FileSystem and have a default implementation of them which is using currently existing synchronous interfaces.

Change History (1)

comment:1 Changed 2 years ago by sergz

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.