Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#5152 closed defect (fixed)

ABB doesn't load default filter lists after fresh install

Reported by: jand Assignee:
Priority: P1 Milestone: Adblock-Browser-for-iOS-1.5.2
Module: Adblock-Browser-for-iOS Keywords:
Cc: mario Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: yes Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

Description

Environment

This is only iOS 10 issue.

How to reproduce

  1. Remove previous installation of ABB
  2. Install ABB from HA
  3. Open ABB and proceed to the dashboard view
  4. Open ABP settings

Observed behaviour

No filter list is load after fresh install and acceptable ads are disabled in the settings. Ad blocking is not working.

The issue is caused by not working of fetch API. We have to patch fetch function in order to get it working in extension environment.

Expected behaviour

One language filter list should be installed and acceptable ads should be enabled

Change History (3)

comment:1 Changed 6 months ago by mario

  • Cc mario added
  • Priority changed from Unknown to P1
  • Ready set

comment:2 Changed 6 months ago by mario

  • Milestone set to Adblock-Browser-for-iOS-1.5.2
  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 6 months ago by scheer

  • Tester changed from Unknown to Scheer
  • Verified working set

AA is loaded correctly and the correct language list is loaded upon a new installation of ABB iOS.

iPhone 6S Plus
iOS 10.2.1
ABB 1.5.2-1531 (Testflight)

Note: See TracTickets for help on using tickets.