Opened 3 years ago

Closed 3 years ago

Last modified 2 years ago

#5184 closed change (fixed)

Support additional webRequest types reported by Firefox

Reported by: trev Assignee: mjethani
Priority: P2 Milestone: Adblock-Plus-1.13.3-for-Chrome-Opera
Module: Platform Keywords:
Cc: mjethani Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29421712/

Description (last modified by sebastian)

Background

See https://developer.mozilla.org/en-US/Add-ons/WebExtensions/API/webRequest/ResourceType - the types reported by webRequest in Firefox aren't the same ones that Chrome supports. In particular, "xbl", "xslt", "beacon", "xml_dtd", "imageset", "web_manifest" are new.

What to change

Make sure that "xbl", "xslt", "xml_dtd", "web_manifest" are treated the same as "other." Make sure that "beacon" is treated same as "ping" and "imageset" same as "image" - this is the aliasing used by the legacy Firefox extension.

Hints for testers

This change should not have any visible effect on Chrome. In order to make sure that it doesn't, you can check the resource types reported in the devtools panel.

Change History (8)

comment:1 Changed 3 years ago by sebastian

  • Priority changed from Unknown to P2
  • Ready set

comment:2 Changed 3 years ago by mjethani

The following resource types are confirmed supported in Firefox 53:

  • beacon
  • font
  • image
  • imageset (sometimes reported as image)
  • main_frame
  • media
  • object
  • other (e.g. text/x-safeframe)
  • ping (if enabled in about:config)
  • script
  • stylesheet
  • sub_frame
  • websocket (reported with http[s]:// URL)
  • xmlhttprequest

I did not check the following types since we probably don't care about these:

  • csp_report
  • web_manifest
  • xbl
  • xml_dtd
  • xslt

Service workers, while not reported in Chrome at all, are reported as script in Firefox.

comment:3 Changed 3 years ago by mjethani

  • Owner set to mjethani

comment:4 Changed 3 years ago by mjethani

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:5 Changed 3 years ago by abpbot

A commit referencing this issue has landed:
Issue 5184 - Support Firefox-specific webRequest types

comment:6 Changed 3 years ago by mjethani

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:7 Changed 2 years ago by sebastian

  • Description modified (diff)
  • Milestone set to Adblock-Plus-for-Chrome-Opera-next

comment:8 Changed 2 years ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Implemented. This hasn't broken anything in Chrome as far as I can tell so will mark verified. I need to check this properly once #5316 is implemented (and #5386 fixed).

ABP 1.13.2.1785
Firefox 55 (Developer) / Windows 7
Chrome 49 / 58 / Windows 7

Note: See TracTickets for help on using tickets.