Opened 5 months ago

Closed 3 months ago

Last modified 2 months ago

#5223 closed defect (fixed)

App is freezing sometimes

Reported by: diegocarloslima Assignee: jwangenheim
Priority: P2 Milestone: Adblock-Plus-for-Samsung-Browser-1.1.1
Module: Adblock-Plus-for-Samsung-Browser Keywords:
Cc: diegocarloslima Blocked By:
Blocking: Platform: Samsung Browser
Ready: yes Confidential: no
Tester: Unknown Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29445587/

Description

Environment

ABP for Samsung Internet 1.0.4
Galaxy S7 Edge
Android 6.0.1

How to reproduce

  1. Go to 'Configure your filter lists'
  2. Check all filter lists
  3. Press back
  4. Go again to 'Configure your filter lists'
  5. If necessary, repeat steps 3 and 4

Observed behaviour

The app freezes for a few seconds. That also happens when selecting 'More blocking options' or whitelisting a couple of websites. It seems to that too much work is being performing on the main thread. Needs to better investigate the root of that issue, but it seems to be caused by IO operations.

Expected behaviour

The application's UI should be responsive in order to provide a better UX.

Change History (7)

comment:1 Changed 5 months ago by jwangenheim

  • Owner set to jwangenheim

comment:2 Changed 4 months ago by jwangenheim

  • Status changed from new to reviewing

comment:3 Changed 4 months ago by jwangenheim

  • Review URL(s) modified (diff)

comment:4 Changed 3 months ago by jwangenheim

  • Milestone set to Adblock-Plus-for-Samsung-Browser-next

comment:5 Changed 3 months ago by abpbot

A commit referencing this issue has landed:
Issue 5223 - App is freezing sometimes

comment:6 Changed 3 months ago by jwangenheim

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:7 Changed 2 months ago by rscott

  • Verified working set
Note: See TracTickets for help on using tickets.