Opened 22 months ago

Last modified 22 months ago

#5224 new defect

Video won't load on ABB iOS when adblocking is enabled

Reported by: misha Assignee:
Priority: Unknown Milestone:
Module: Adblock-Browser-for-iOS Keywords: pre-roll, video, ad, block
Cc: Blocked By:
Blocking: Platform: iOS
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Adblock Browser 1.5.2 on iOS 10.2.1 (iPhone 6s)

How to reproduce

  1. Go to m.tmz.com on Adblock Browser (after ensuring ad blocking is enabled)
  2. Select a video article (I was using this one http://www.tmz.com/2017/05/08/hunter-daily-conrad-hilton-arrest/ )
  3. Try to play video
  4. Fail and be sad (or succeed and close ticket =P)

Observed behaviour

Video loading image would spin and spin, but no video ever loaded. If I turned off the ad blocking options and refreshed the page, the video would load normally. There is a pre-roll ad which displays on some browsers, but it did not display on ABB even after I disabled ad blocking.

Expected behaviour

The video should play, and the pre-roll ad should not.

Attachments (1)

IMG_0231.jpg (309.0 KB) - added by misha 22 months ago.

Download all attachments as: .zip

Change History (3)

comment:1 Changed 22 months ago by mario

Unfortunately I couldn't reproduce the issue using ABB 1.5.2 on iOS 10.2.1 (iPhone 6). TMZ seems to be a bit slow at times but all videos worked fine for me. Let me dig a bit deeper:

  • Does the same error still occur for you using the URL you linked in the issue?
  • After tapping play on a video, does anything happen? (Spinner-icon is shown? Video player opens but is blank?)
  • Do other websites playing video work fine for you? (e.g. youtube.com)

Changed 22 months ago by misha

comment:2 Changed 22 months ago by misha

I performed the steps you provided me via email (below) and am still having the issue on TMZ with videos.

  1. Start ABB
  2. Make sure ad blocking is enabled and Acceptable Ads is disabled
  3. Kill ABB by double-tapping the home button and swiping up on ABB
  4. Open ABB
  5. Visit tmz.com -> do videos still not play?

After tapping play, the spinner icon is shown, and continues to spin. I waited over a minute with no load. Videos on other sites (radaronline.com and youtube.com) play quickly with no issue.

Note: See TracTickets for help on using tickets.