Opened 3 years ago

Closed 2 years ago

#5236 closed change (duplicate)

Update the abp2blocklist dependency to SOME_REVISION for Safari

Reported by: mjethani Assignee:
Priority: P3 Milestone:
Module: Platform Keywords:
Cc: sebastian, kzar Blocked By: #3673
Blocking: Platform: Safari
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by kzar)

Background

The content blocking API in Safari imposes a limit of 50,000 rules. When using EasyList and similar large subscriptions that can be quickly hit. Therefore for #3673 we have started merging similar rules together. We now need to update the abp2blocklist dependency in the safari branch of adblockpluschrome.

Additionally the following unrelated abp2blocklist changes will be included:

  1. SOME_CHANGE
  2. SOME_CHANGE

What to change

  1. Update abp2blocklist dependency to SOME_REVISION.
  2. Pass in the merge option to contentBlockerList.generateRules, if it remains an option.
  3. Optionally, if it makes sense, do not pass in the merge option if we know the rule set is already small enough.

Hints for testers

  1. Test that the experimental content blocking option still works in Safari.
  2. Test that a combined filter list such as EasyList Hebrew + Easylist can now be added.
  3. Test that SOME_CHANGE that was also included with the dependency update didn't break SOME_FEATURE.

Change History (2)

comment:1 Changed 3 years ago by kzar

  • Description modified (diff)
  • Priority changed from Unknown to P4
  • Summary changed from Use new rule merging feature in abp2blocklist to Update the abp2blocklist dependency to SOME_REVISION for Safari

I've updated the issue description and title to show what's normally included in dependency update issues. We'll need to come back to it and fill in the details once the related abp2blocklist change actually lands.

comment:2 Changed 2 years ago by sebastian

  • Priority changed from P4 to P3
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5464.

Note: See TracTickets for help on using tickets.