Opened 2 years ago

Closed 2 years ago

#5268 closed defect (fixed)

"file a request here" link in web extension build of ABP FF points to nonexisting URL

Reported by: philll Assignee: paco
Priority: Unknown Milestone:
Module: Infrastructure Keywords:
Cc: trev Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29460563/

Description (last modified by philll)

Environment

Firefox >=50

How to reproduce

  1. Click the ABP icon
  2. Click the "General" tab
  3. Click the "file a request here" link

Observed behaviour

Nginx shows an HTTP 404 on this URL: https://adblockplus.org/redirect?link=firefox_support&lang=en-US

Expected behaviour

A redirect should point to the ABP for FF forum.

Change History (9)

comment:1 Changed 2 years ago by ferris

Hi Phil, some questions:

  • Can you say what the 404 URL is?
  • Has the web extension build been released?
  • Is this URL communicated or used anywhere else?

comment:2 Changed 2 years ago by philll

  • Description modified (diff)

I guess all in all, we could have filed this ticket as change request as well, I went the bug route since it's already in some build.

comment:3 follow-up: Changed 2 years ago by ferris

I asked the extension devs, but didn't get any answer. I personally think it makes sense to have a more durable redirect instead of that very concrete URL to the old forum, especially as we are discussing new forum options and different support channels.

Last edited 2 years ago by ferris (previous) (diff)

comment:4 Changed 2 years ago by philll

  • Cc trev added

Until we retire the forum and replace it with anything else, this is the very place of support.

comment:5 in reply to: ↑ 3 Changed 2 years ago by trev

Replying to ferris:

I personally think it makes sense to have a more durable redirect instead of that very concrete URL to the old forum, especially as we are discussing new forum options and different support channels.

This is the durable redirect ;-)

The redirect is handled in the infrastructure repository, file modules/web/templates/adblockplus.org.conf.erb. We already have redirects for various platforms there, so we merely need to add firefox_support to the list - this key is new, the legacy Firefox extension doesn't link to any support page.

comment:6 Changed 2 years ago by paco

  • Owner set to paco

comment:7 Changed 2 years ago by paco

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:8 Changed 2 years ago by abpbot

A commit referencing this issue has landed:
Issue 5268 - Redirect firefox support link to forum thread

comment:9 Changed 2 years ago by matze

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.