Opened 2 years ago

Closed 2 years ago

#5270 closed defect (fixed)

Failed to compile on Windows

Reported by: cm.sanchi Assignee:
Priority: P5 Milestone:
Module: Libadblockplus Keywords:
Cc: sergz Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

E:\libadblockplus-master>ensure_dependencies.py
INFO: Cloning repository https://hg.adblockplus.org/googletest-github into E:\libadblockplus-master\t
hird_party\googletest
Traceback (most recent call last):

File "E:\libadblockplus-master\ensure_dependencies.py", line 382, in <module>

resolve_deps(repo)

File "E:\libadblockplus-master\ensure_dependencies.py", line 326, in resolve_deps

ensure_repo(repodir, parenttype, target, vcs, _root.get(vcs, ""), source)

File "E:\libadblockplus-master\ensure_dependencies.py", line 270, in ensure_repo

repo_types[type].clone(url, target)

File "E:\libadblockplus-master\ensure_dependencies.py", line 55, in clone

subprocess.check_call(["hg", "clone", "--quiet", "--noupdate", source, target])

File "C:\Python27\lib\subprocess.py", line 536, in check_call

retcode = call(*popenargs, kwargs)

File "C:\Python27\lib\subprocess.py", line 523, in call

return Popen(*popenargs, kwargs).wait()

File "C:\Python27\lib\subprocess.py", line 711, in init

errread, errwrite)

File "C:\Python27\lib\subprocess.py", line 959, in _execute_child

startupinfo)

WindowsError: [Error 2] The system cannot find the file specified

E:\libadblockplus-master>python -V
Python 2.7.12

E:\libadblockplus-master>

Change History (4)

comment:1 Changed 2 years ago by hfiguiere

  • Component changed from Unknown to Libadblockplus

comment:2 Changed 2 years ago by sergz

Do you have hg available from the command line?

comment:3 Changed 2 years ago by sergz

  • Cc sergz added
  • Platform changed from Internet Explorer to Unknown / Cross platform
  • Priority changed from Unknown to P5

Set low priority because it's not reproducible locally and it seems the issue on the user-side.

comment:4 Changed 2 years ago by sergz

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.