Opened 2 months ago

Closed 2 months ago

Last modified 7 weeks ago

#5279 closed defect (fixed)

Adblock Plus 2.9 broken in Thunderbird

Reported by: tibitts Assignee: trev
Priority: P1 Milestone: Adblock-Plus-2.9.1-for-Firefox
Module: Adblock-Plus-for-Firefox Keywords:
Cc: greiner, trev Blocked By:
Blocking: Platform: Thunderbird
Ready: yes Confidential: no
Tester: Unknown Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29450608/

Description

Environment

Linux OpenSUSE 13.2 32-bit, Thunderbird 52.1.1, ABP 2.9
filter lists: Easy Privacy + Easy List, Easy List Germany, Facebook Privacy List, Fanboys Social Blocking List, Malware Domains, Adblock Warming Removal List, Prebake - Filter Obtrusive Cookie Notices

How to reproduce

Reading articles from a RSS news feed, doesn't matter which one, as long as there are ads

Observed behaviour

Suddenly ads did appear in the articles. Upon checking the filter list subscriptions - they were all gone.
Even though the filter subscriptions can be re-created, they will be lost again after Thunderbird is restarted.
Reverting to ABP 2.8.2 restores the filter subscriptions.

Expected behaviour

Filter subscriptions should not be lost.
Is this already the point were Thunderbird doesn't cope any more with the changes in preparation for web extensions?
If that's the case, ABP 2.9 shouldn't be marked as compatible with Thunderbird any longer.

Change History (12)

comment:1 Changed 2 months ago by tibitts

Platform should be Thunderbird, not Firefox.

comment:2 Changed 2 months ago by mapx

  • Platform changed from Firefox to Thunderbird

comment:3 Changed 2 months ago by hansenjo

I have the same problem on macOS 10.12.5 with Thunderbird 52.1.1 and ABP 2.9. ABP loses all the filter lists on restart. It doesn't matter which lists, even custom rules are affected. One can re-add them, but they aren't presistent between restarts. Reverting to ABP 2.8.2 fixes it. I've disabled automatic updates of my Thunderbird add-ons for now ...

comment:4 Changed 2 months ago by mapx

  • Cc greiner trev added

comment:5 Changed 2 months ago by trev

  • Component changed from Unknown to Adblock-Plus-for-Firefox
  • Priority changed from Unknown to P1
  • Ready set

There is no actual data loss here, but Adblock Plus I/O is completely dysfunctional. This is because the communication with the embedded WebExtension doesn't work. From some quick debugging, the issue doesn't seem to be that the WebExtension didn't start up. However, the WebExtension didn't establish a connection to the main extension for some reason, and all communication ends up waiting for that connection.

comment:6 Changed 2 months ago by trev

From the look of it, the embedded WebExtension started up "correctly" - the issue rather seems to be that WebExtensions are generally broken on Thunderbird and the code in the background page didn't even run.

comment:7 Changed 2 months ago by trev

And I finally got to the root of the issue - while all the code is theoretically in place, Thunderbirds left the webextension-scripts category empty so that none of the WebExtensions APIs started up. Theoretically, the embedded WebExtension loaded. Practically, it has no APIs to use, in particular not the backgroundPage API. It's the same with SeaMonkey but you'd have to install a pre-release version to hit this issue - the current release is outdated and incompatible with Adblock Plus 2.9.

comment:8 Changed 2 months ago by trev

  • Owner set to trev

comment:9 Changed 2 months ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:10 Changed 2 months ago by abpbot

A commit referencing this issue has landed:
Issue 5279 - Fix broken I/O in non-Firefox applications

comment:11 Changed 2 months ago by trev

  • Milestone set to Adblock-Plus-for-Firefox-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:12 Changed 7 weeks ago by Ross

  • Verified working set

Fixed. ABP works as expected in Thunderbird and keeps settings after restarts.

ABP 2.9.0.4252-beta
Thunderbird 52.1.1 / Windows 7
Seamonkey 2.48 / Windows 7

Last edited 7 weeks ago by Ross (previous) (diff)
Note: See TracTickets for help on using tickets.