Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#530 closed defect (fixed)

patterns.ini isn't being written on Firefox 20 (Permission denied)

Reported by: trev Assignee:
Priority: P1 Milestone: Adblock-Plus-2.6.2-for-Firefox
Module: Adblock-Plus-for-Firefox Keywords:
Cc: smultron45@…, jobp@… Blocked By:
Blocking: #153 Platform: Firefox
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/4951638452207616

Description

Environment

Adblock Plus 2.6, Firefox 20, Windows 7 x64

How to reproduce

  1. Change anything in the Filter preferences.

Observed behaviour

patterns.ini.tmp file is being written but not renamed into patterns.ini. Error Console shows: "Win error 5 during operation move (Permission denied). The patterns.ini file is stuck in its original state.

Expected behaviour

patterns.ini should be replaced by new data.

Change History (11)

comment:1 Changed 6 years ago by mapx

  • Cc smultron45@… added

comment:2 Changed 6 years ago by trev

Apparently, this was fixed in Firefox 23, between the nightly builds 2013-04-23 and 2013-04-24. The changes for that day are: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=acf388eaf9e9&tochange=fef5f202b2dc

Interestingly, elemhide.css is being overwritten correctly even though it should be using exactly the same code.

comment:3 Changed 6 years ago by trev

Some more investigation: for some reason, OS.File.move() indeed cannot overwrite that particular patterns.ini file (reproducible from Scratchpad). If I create a copy of that file then this one can be overwritten. All permissions are inherited in both cases, cacls.exe output is identical. Same goes for the files produced with icacl.exe /save, the info saved there is absolutely identical.

comment:4 Changed 6 years ago by trev

Stupid me, the file is simply locked and cannot be removed because of that (thanks fhd). So our code reading patterns.ini leaves it locked for some reason, this isn't an issue for elemhide.css because we don't read it.

comment:5 Changed 6 years ago by trev

And that means that bug 858723 is the issue here - I guess we get file ID 0 for patterns.ini which prevents OS.File.close() from working correctly.

comment:6 Changed 6 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:7 Changed 6 years ago by trev

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:8 Changed 6 years ago by trev

  • Milestone set to Adblock-Plus-for-Firefox-next

comment:9 Changed 6 years ago by jobp

  • Cc jobp@… added

comment:10 Changed 5 years ago by trev

  • Blocking 153 added
  • Platform set to Firefox/Firefox Mobile

comment:11 Changed 5 years ago by philll

  • Platform changed from Firefox/Firefox Mobile to Firefox

Made Firefox and Firefox mobile available as seperate platforms.

Note: See TracTickets for help on using tickets.