Opened 5 months ago

Last modified 5 months ago

#5328 new defect

Adblock Browser sometimes shows ads after start-up

Reported by: mario Assignee:
Priority: P2 Milestone:
Module: Adblock-Browser-for-iOS Keywords:
Cc: scheer Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

ABB 1.5.3
Any iOS version

How to reproduce

Way of reproduction 1

  1. Open ABB and browse to a website where ads are blocked (e.g. yahoo.com)
  2. Force-quit ABB by double-pressing the home button and swiping up on ABB
  3. Open ABB

(This way of reproduction, even though theoretically valid, hasn't turned out to successfully reproduce the issue yet)

Way of reproduction 2

  1. Open ABB
  2. Try to forcefully get ABB to crash (by browsing between tmz.com and radaronline.com for example)
  3. After ABB crashed, re-open ABB

Observed behaviour

Sometimes, after re-opening ABB (it's not clear yet, whether ABB needs to crash for this to appear -- see way of reproduction), ads are shown on the website still opened. After reloading the website, the ads are gone.

Expected behaviour

No ads are shown after re-opening ABB

Change History (1)

comment:1 Changed 5 months ago by mario

The issue stems from ABP not being initialized on time. Thus there's two stated ways of reproduction. However, so far we've only been able to reproduce it after ABB crashed. If this turns out to be true, the first way of reproduction can be removed.

Note: See TracTickets for help on using tickets.