Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#5346 closed defect (duplicate)

Cannot map dependency resource to non-existent directory

Reported by: greiner Assignee:
Priority: Unknown Milestone:
Module: Automation Keywords:
Cc: sebastian, trev Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Ubuntu 16.04

How to reproduce

  1. Replace i18n.js = adblockplusui/i18n.js in "adblockpluschrome/metadata.chrome" with foo/i18n.js = adblockplusui/i18n.js
  2. Run build.py -t chrome devenv

Observed behaviour

The "devenv.chrome" directory doesn't contain the directory "foo".

Expected behaviour

The "devenv.chrome" directory contains the directory "foo" which contains the file "i18n.js".

Change History (5)

comment:1 Changed 2 years ago by sebastian

  • Cc trev added

This is because only a hard-coded list of directories make it into the build and mappings to non-existing directories are ignored rather than creating that directory. From the top of my head, I cannot think of any reason why it was implemented this way, other than perhaps to simplify the logic.

trev, do you remember any reason, why we should keep that logic?

comment:2 Changed 2 years ago by kzar

I'm pretty sure I opened a codereview to fix this some time ago, let me see if I can find it.

comment:3 Changed 2 years ago by sebastian

  • Resolution set to duplicate
  • Status changed from new to closed

I'm not aware of any code review, but this seems to be a duplicate of #3967.

comment:4 Changed 2 years ago by kzar

Looks like I forgot to add the codereview to that issue originally, I've found it and added it now.

comment:5 Changed 2 years ago by trev

We use the whitelist approach for packaging so that we don't package up unrelated content by mistake (devenv, buildtools, some test data). This concern doesn't apply to mapped files however, so directories for mapped files should always be created.

Note: See TracTickets for help on using tickets.