Opened 2 years ago

Closed 2 years ago

#5353 closed defect (fixed)

Writing filters documentation does not include latest filter changes.

Reported by: Ross Assignee: hfiguiere
Priority: P3 Milestone:
Module: Websites Keywords:
Cc: hfiguiere, sebastian, lisabielik, wspee, greiner Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29482703/

Description (last modified by Ross)

Environment

N/A.

How to reproduce

  1. Visit https://adblockplus.org/filters

Observed behaviour

Newer filter features are not described at all on the Writing filters documentation page. This includes new filter options, such as $websocket and $webrtc, along with documentation about property filters.

These are currently described in various blog posts such as:

Expected behaviour

The Writing filters page to describe all currently available/public filter options and syntax.

Change History (16)

comment:1 Changed 2 years ago by Ross

  • Description modified (diff)

comment:2 Changed 2 years ago by hfiguiere

  • Cc hfiguiere added

comment:3 Changed 2 years ago by sebastian

  • Cc sebastian added

comment:4 Changed 2 years ago by hfiguiere

  • Owner set to hfiguiere

comment:5 Changed 2 years ago by sebastian

Usually, we update the filter documentation, as soon as we release a new version featuring the new syntax. That said, it would be great if we could land the changed to the documentation next week, on July 12th, when we release Adblock Plus 1.13.3.

comment:6 Changed 2 years ago by hfiguiere

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:7 Changed 2 years ago by hfiguiere

The webrtc and websocket options are already documented.

comment:8 Changed 2 years ago by juliandoucette

  • Cc lisabielik wspee added

I'm guessing that you forgot to have your content reviewed by Lisa?

comment:9 Changed 2 years ago by juliandoucette

  • Priority changed from Unknown to P3

comment:10 follow-up: Changed 2 years ago by greiner

  • Cc greiner added

We removed support for the simplified element hiding filter syntax while introducing the new one for element hiding emulation filters in #5287. Therefore I'd suggest also removing any references to those from /filters and /filter-cheatsheet.

comment:11 in reply to: ↑ 10 ; follow-up: Changed 2 years ago by hfiguiere

Replying to greiner:

We removed support for the simplified element hiding filter syntax while introducing the new one for element hiding emulation filters in #5287. Therefore I'd suggest also removing any references to those from /filters and /filter-cheatsheet.

We just removed [-abp-properties=] and this didn't have any mention in the documentation anyway. The simplified element hiding filter still exist and work (the ## rules)

comment:12 in reply to: ↑ 11 Changed 2 years ago by greiner

Replying to hfiguiere:

We just removed [-abp-properties=] and this didn't have any mention in the documentation anyway. The simplified element hiding filter still exist and work (the ## rules)

I'm not referring to regular element hiding filters (e.g. example.com##div#foo) but to the variant that doesn't use CSS selectors (e.g. example.com#div(id=foo)).

See https://adblockplus.org/en/filters#elemhide_simplified

comment:13 follow-up: Changed 2 years ago by hfiguiere

oh ! my bad, I misunderstood.

Maybe an issue should be filed for this one.

We should IMHO get a complete documentation review and editing.

comment:14 in reply to: ↑ 13 Changed 2 years ago by greiner

Replying to hfiguiere:

oh ! my bad, I misunderstood.

No worries. They've been deprecated for years already so most people have probably never heard of them.

Maybe an issue should be filed for this one.

We should IMHO get a complete documentation review and editing.

Ok, that's fine. I thought it'd be reasonable to post here first since this ticket concerns including the latest filter changes and since it hasn't been set to "ready" yet.

Anyway, I created #5454 for the removal of the documentation of the simplified syntax now.

comment:15 Changed 2 years ago by abpbot

A commit referencing this issue has landed:
Issue 5353 - Add advanced element hiding filters documentation

comment:16 Changed 2 years ago by hfiguiere

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.