Opened 2 years ago

Closed 2 years ago

#5356 closed defect (fixed)

"Acceptable Ads" do not meet criteria on mobile

Reported by: misha Assignee:
Priority: Unknown Milestone:
Module: Adblock-Browser-for-Android Keywords:
Cc: arthur, mario, scheer, diegocarloslima Blocked By:
Blocking: Platform: Adblock Browser for Android
Ready: no Confidential: no
Tester: Scheer Verified working: no
Review URL(s):

http://uk.reuters.com/article/uk-britain-hillsborough-idUKKBN19J15G
http://uk.reuters.com/article/uk-britain-boe-carney-idUKKBN19J1VI

Description

Environment

Samsung Galaxy S7; Android version 6.0.1; ABB for Android Version 1.1.1
Adblock Settings: English EasyList, Disable tracking, malware domains, anti-adblocking messages, and social media buttons all enabled. Acceptable Ads set to allow.

How to reproduce

  1. Ensure adblocking is enabled, acceptable ads are allowed, and all other blocking features are enabled
  2. Go to reuters.com (or uk.reuters.com - both have mobile versions)
  3. Select an article (I was on this one: http://uk.reuters.com/article/uk-britain-hillsborough-idUKKBN19J15G)
  4. See inline add disrupting content, some breaking multiple acceptable ads standards

Observed behaviour

I first observed an ad on the home page, which seemed to be almost "acceptable" (it was static, and did not break up content, but did seem to take more than 25% of the screen). Upon selecting an article, the same ad was displayed, but within the article, breaking the placement rule.

Initially Mario thought this may be explainable by the fact that this ad is "acceptable" on desktop, but the same ad on mobile does not quite meet our criteria. However, on further testing, larger, sometimes animated ads begin to display. These took up 100% of the mobile screen (screenshots attached) and one even auto-played with some sound before pausing (or muting, the sound could've been a glitch; not really sure, but it came to a stop). These ads DEFINITELY do not meet the acceptable ads standards.

PS. On the desktop version of the site, the corresponding offending ads are now loading as a blank space on the top of the right column, while additional (seemingly acceptable) ads that were not displaying earlier today are now appearing (both as a top banner and further down the right rail); additionally, sponsored content (which was previously acceptable outbrain ads) is displaying as white space currently as well. Not sure whether that's related, or possibly a separate issue...

Expected behaviour

Only ads meeting the acceptable ads criteria should be displayed while Adblocking is enabled and Acceptable Ads are allowed, regardless of platform.

Attachments (2)

UnacceptableAdsOnReuters.zip (11.8 MB) - added by misha 2 years ago.
various screenshots of offending ads on mobile
ABPenabled_ReutersAdProbs_Bank of England's Carney says BoE will debate rate rise in 'coming months' - Reuters_Screenshot_2017-06-28_19-26-53.png (918.4 KB) - added by misha 2 years ago.
presumably corresponding desktop ad (white space)

Change History (14)

Changed 2 years ago by misha

various screenshots of offending ads on mobile

comment:1 Changed 2 years ago by misha

Oh - I also just noticed that on earlier screenshots the social media buttons are blocked (but there is white space where they would be) - but as the issue worsened, the social media icons were no longer blocked. Seems to be very similar to the issue we were having on iOS.

comment:2 Changed 2 years ago by scheer

@arthur: Could this simply be a false positive? Probably a good idea to check that. Do you need to corresponding url (I could dev tool pull it from mobile view in chrome). I am imagining here that it is not as much ABB not blocking it, but it being the mobile version of the site and different ad styles/url's being served.

I will check this against 1.2.0 either way, to see if it actualy is a blocking issue itself.

comment:3 Changed 2 years ago by scheer

@misha: Presumably the Disable Social media buttons option was enabled in the settings of Ad Blocking? If so, then how long after you had that option enabled did the buttons take to appear? A few minutes of browsing? 10 minutes?

comment:4 Changed 2 years ago by misha

@scheer apparently it was roughly 17 minutes from the time I began surfing the site. And yes, I had enabled the "Disable social media buttons" option earlier that morning (at 10:47 per screenshot).

More data: Per the screenshots I took (sorry I didn't attach them all) I started browsing and saw the first ad at 14:51, then have a screenshot from 14:57 where the social media icons are not displayed (though there is white space, and an ad in the middle of the article). Finally at 15:08 I have a screenshot with the social media buttons (and ironically no ad, just the word 'advertisement'). At 15:19 I saw the first animated ad, and the social media buttons remained.

comment:5 Changed 2 years ago by arthur

The exception rules for reuters.com have been removed 2 days ago so I think this should no longer be an issue.

comment:6 Changed 2 years ago by scheer

@misha: As I am unable to correctly reproduce this, would you be able to check to see if the removed exception rules stop this occurring for you?

@arthur: Would this also cause issues with AA being displayed? As it would appear that now no AA's are displayed in articles.

comment:7 Changed 2 years ago by misha

So far so good on no unacceptable ads occurring. I did instead discover that clicking on the blank space where social media icons are being 'hidden' actually still takes you to their respective sites. I've uploaded a video - https://drive.google.com/open?id=0Bw7e0UaUxdzGQ3RlbEl1UENYSGc

comment:8 Changed 2 years ago by arthur

@Scott
As far as I can see there shouldn't be any AA anymore. RevContent and Taboola ads are still whitelisted for them but they don't seem to use them.

@Misha
Should ne resolved with the latest version of the social blocking list. Since there is no way to manually update the filter lists, you would need to re-install ABB to verify.

comment:9 Changed 2 years ago by scheer

  • Cc diegocarloslima added

@diegocarloslima - I am unable to reproduce the above-mentioned issue, but it is quite obviously there. I wonder if this is still some sort of engine initialization issue on that device.

comment:10 Changed 2 years ago by scheer

@arthur: Ok, so this seems more of an issue with the site just not applying RevContent or Taboola ads at all. So, it's not that it's blocked, just that they use something else?

comment:11 Changed 2 years ago by arthur

Exactly.

comment:12 Changed 2 years ago by scheer

  • Resolution set to fixed
  • Status changed from new to closed
  • Tester changed from Unknown to Scheer

The AA issue has now been addressed here, but the secondary issue of the Social Media buttons is now covered in #5377.

Note: See TracTickets for help on using tickets.