Opened 2 years ago

Closed 2 years ago

#5358 closed defect (worksforme)

Disable anti-ad blocking feature does not fetch Adblock Warning Removal List

Reported by: scheer Assignee:
Priority: Unknown Milestone:
Module: Adblock-Browser-for-Android Keywords:
Cc: diegocarloslima, mario Blocked By:
Blocking: Platform: Adblock Browser for Android
Ready: no Confidential: no
Tester: Scheer Verified working: no
Review URL(s):

Description

When the user selects 'Disable anti-ad blocking' the Adblock Warning Removal List list should be fetched and applied, but when the user selects this option, no filter is fetched.

All other filter selections within 'More Blocking Options' are fetched correctly.

Environment

adblockbrowser-1.1.1.20170612182010-arm
Galaxy S7
Android
7.0

How to reproduce

  1. Select settings
  2. Select Ad blocking
  3. Select More blocking options
  4. Select 'Disable anti-ad blocking messages'

Observed behaviour

Adblock Warning Removal List is not fetched.

Expected behaviour

Adblock Warning Removal List is fetched.

Attachments (1)

defc79c9-b006-4800-b7a3-59ae34da148b.jpeg (62.6 KB) - added by diegocarloslima 2 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 2 years ago by mario

@diegocarloslima, is it possible to address that before the release of 1.2.0?

Changed 2 years ago by diegocarloslima

comment:2 Changed 2 years ago by diegocarloslima

I couldn't reproduce this issue. The 'Disable anti-adblocking' list seems to be working fine. What I did was navigate to https://www.bychico.net/. With anti-adblocking list disabled, a 'Disable your AD Blocker' message is shown (See screenshot). With it enabled, the message wasn't shown anymore.

Environment

adblockbrowser-1.1.1.20170612182010-arm and also ABB 1.2.0
OnePlus 5
Android 7.1.1

comment:3 Changed 2 years ago by diegocarloslima

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.