Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#5360 closed defect (fixed)

Whitelist subscription shown as '-user-35236'

Reported by: scheer Assignee: diegocarloslima
Priority: P4 Milestone: Adblock-Browser-for-Android-1.2.0
Module: Adblock-Browser-for-Android Keywords:
Cc: diegocarloslima, mario Blocked By:
Blocking: Platform: Adblock Browser for Android
Ready: yes Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29505606/

Description (last modified by diegocarloslima)

When the user unselects the 'block ads on this website' from the options menu, a whitelist subscription is created for the site and placed into 'More blocking options' with a title similar to '-user-35236'. The whitelist subscription should have a more meaningful name as opposed to a generic user/number reference.

Environment

adblockbrowser-1.1.1.20170612182010-arm
Galaxy S7
Android 7.0

How to reproduce

  1. Visit any web page
  2. Select the settings menu
  3. De-select 'Block ads on this site'
  4. Go to settings page
  5. Go to Ad blocking
  6. Go to 'More blocking options'

Observed behaviour

A whitelist subscription named '-user-35236' or similar is shown.

Expected behaviour

The whitelist subscription should have a comprehensive name (e.g. Whitelisted websites).

Change History (9)

comment:1 Changed 2 years ago by diegocarloslima

This seems to be due to some internal change in ABP after updating it to 2.7.3. It used to return 'Exception Rules' as a title for the whitelisting subscription. Now, it returns null for the title and with that, the url is being used instead, which is ~user~ and some random number.

comment:2 Changed 2 years ago by diegocarloslima

  • Description modified (diff)

comment:3 Changed 2 years ago by diegocarloslima

  • Summary changed from User added whitelist shown as '-user-35236' and not the URL name to Whitelist subscription shown as '-user-35236'

comment:4 Changed 2 years ago by diegocarloslima

  • Owner set to diegocarloslima
  • Priority changed from Unknown to P4
  • Ready set

comment:5 Changed 2 years ago by diegocarloslima

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:6 Changed 2 years ago by abpbot

A commit referencing this issue has landed:
Issue 5360 - Whitelist subscription shown as '-user-35236'

comment:7 Changed 2 years ago by diegocarloslima

  • Milestone set to Adblock-Browser-for-Android-1.2.0
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:8 Changed 2 years ago by abpbot

A commit referencing this issue has landed:
Issue 5360 - Whitelist subscription shown as '-user-35236'

comment:9 Changed 2 years ago by rscott

  • Verified working set

LGTM

Note: See TracTickets for help on using tickets.