Opened 2 years ago

Closed 23 months ago

Last modified 23 months ago

#5375 closed defect (fixed)

ABB Widget has Google as default search engine instead of Duck Duck Go

Reported by: scheer Assignee: diegocarloslima
Priority: P4 Milestone: Adblock-Browser-for-Android-1.3.0
Module: Adblock-Browser-for-Android Keywords:
Cc: diegocarloslima, mario Blocked By:
Blocking: Platform: Adblock Browser for Android
Ready: yes Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29552607

Description

On first installation, the ABB Widget shows the default search engine as Google instead of Duck Duck Go. The browser correctly displays Duck Duck Go as the default search engine, but the widget does not pick up any change until the first time a different Search Engine is selected.

Environment

adblockbrowser-1.1.1.20170612182010-arm
Galaxy S7
Android 7.0

How to reproduce

  1. Install ABB Android
  2. Select Widgets from the home screen and place the ABB Widget on the Android desktop
  3. Select the search field in the ABB Widget from the desktop

Observed behaviour

Default search engine is Google.

Expected behaviour

Duck Duck Go is the default search provider.

Change History (9)

comment:1 Changed 2 years ago by diegocarloslima

This still happens in ABB 1.2.0

comment:2 Changed 2 years ago by diegocarloslima

  • Priority changed from Unknown to P3
  • Ready set

comment:3 Changed 2 years ago by diegocarloslima

  • Priority changed from P3 to P4

comment:4 Changed 2 years ago by diegocarloslima

  • Owner set to diegocarloslima

comment:5 Changed 2 years ago by diegocarloslima

This is due to the fact that the search widget has a different logic for retrieving the default search engine. Instead of retrieving the search engine based on the preference browser.search.order, defined in mobile.js, which is the way it's retrieved in SearchPreferenceCategory.java, it retrieves the default search engine by reading a file called browsersearch.json, that is located in the res/raw/ folder. This file is generated by the script generate_browsersearch.py, which takes into consideration what is defined in browser.search.order and browser.search.defaultenginename inside region.properties. This means that we need to adjust the search widget to use the same logic of the search preference.

Version 0, edited 2 years ago by diegocarloslima (next)

comment:6 Changed 2 years ago by diegocarloslima

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing
  • Summary changed from ABB Widget has Google as default search engine instaed of Duck Duck Go to ABB Widget has Google as default search engine instead of Duck Duck Go

comment:7 Changed 23 months ago by diegocarloslima

  • Milestone set to Adblock-Browser-for-Android-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:9 Changed 23 months ago by traynard

  • Verified working set
Note: See TracTickets for help on using tickets.