Opened 2 years ago

Closed 23 months ago

Last modified 20 months ago

#5376 closed defect (fixed)

ABP no longer blocks ads on iOS11

Reported by: traynard Assignee: dzhang
Priority: P2 Milestone:
Module: Adblock-Plus-for-iOS/macOS Keywords:
Cc: mario, jand, tomasnovella Blocked By:
Blocking: Platform: iOS
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

iOS 11 - iPhone 7 - ABP v1.1.0

How to reproduce

  1. Disable AA in the ABP app and ensure Safari settings has ABP enabled as the content blocker
  2. In Safari, Navigate to arstechnica.com
  3. Open any of the top story articles


Observed behaviour

Ads are shown in the following locations:
top of the page (below header), Middle of the article content, and beneath the article navigation (sponsored stories)

Expected behaviour

No ads should be shown when AA is disabled

NOTE: Same behavior when AA is enabled.

Attachments (2)

IMG_0011.PNG (1.6 MB) - added by wmchris 2 years ago.
With enabled abp on ios11
IMG_0012.PNG (1.7 MB) - added by wmchris 2 years ago.
Disabled abp on ios11

Download all attachments as: .zip

Change History (13)

comment:1 Changed 2 years ago by mario

  • Cc jand tomasnovella added

@jand, @tomasnovella, can you look into that?

comment:2 Changed 2 years ago by mario

  • Priority changed from Unknown to P2
  • Ready set

comment:3 Changed 2 years ago by CraftyDeano

This was an issue Apple was aware of affecting iOS 11 Developer Beta 1 & 2 and Public Beta 1.

This has been resolved in Developer Beta 3 of iOS 11 and most likely in the upcoming Public Beta 2.

I could not reproduce this issue on iOS 11 Beta 3 - iPhone 7+ - iOS 11b3

https://download.developer.apple.com/Documentation/Beta_Release_Notes_Jul_10_2017/iOS_11_beta_3_Release_Notes.pdf

Resolved Issues

  • In beta 2 and earlier, Safari Content Blockers may not have blocked content as expected.

Workaround: If a Content Blocker is not working as expected, in Settings > SafarI, toggle the state of the Content Blocker.

Last edited 2 years ago by CraftyDeano (previous) (diff)

comment:4 Changed 2 years ago by mario

@traynard, can you confirm, that it works with iOS beta 3 using the current build?

comment:5 Changed 2 years ago by wmchris

@mario i can not confirm this. Bug still appears on latest public beta. Workaround does not work either

comment:6 Changed 2 years ago by traynard

@mario @wmchris - I am actually seeing this working much better on beta 3 now. The example in this ticket is working as expected now (no ads).

Changed 2 years ago by wmchris

With enabled abp on ios11

Changed 2 years ago by wmchris

Disabled abp on ios11

comment:7 Changed 2 years ago by wmchris

See attached Images. Abp doesnt work on non Public beta3 with disabled aa. Normally this page is adfree with abp. Same problem with pub Beta 2

Last edited 2 years ago by wmchris (previous) (diff)

comment:8 Changed 2 years ago by traynard

@wmchris - what model of iPad are you using? I have tested on iPhone and iPad and am not seeing any ads on the example site in your screenshots.

comment:9 Changed 23 months ago by dzhang

I tested ABP with iOS 11 beta 5 (on iPad Pro) also against arstechnica.com.

Ads were blocked when ABP is active and AA is enabled.

Therefore, ABP appears to be working with the latest beta iOS beta version. For those times when it is not immediately blocking ads after activation of ABP, one or more page refreshes seems to get it to work.

Last edited 23 months ago by dzhang (previous) (diff)

comment:10 Changed 23 months ago by dzhang

  • Resolution set to fixed
  • Status changed from new to closed

comment:11 Changed 20 months ago by dzhang

  • Owner set to dzhang
Note: See TracTickets for help on using tickets.