Opened 2 years ago

Closed 2 years ago

#5379 closed defect (fixed)

Remove top level paths from acceptableads.com

Reported by: juliandoucette Assignee: juliandoucette
Priority: P3 Milestone:
Module: Websites Keywords: goodfirstbug
Cc: wspee, ire Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29535581

Description (last modified by juliandoucette)

Environment

All

How to reproduce

  • Search for href="/, src="/, (/

Observed behaviour

  • See top level paths e.g. [link](/top-level) instead of [link](relative)

Expected behaviour

  • Paths should be relative for testing and localization

Implementation details

I will implement this in two separate patchsets. One for hrefs, and another for srcs, because localized srcs are not supported by our cms test server.

Change History (8)

comment:1 Changed 2 years ago by juliandoucette

  • Description modified (diff)

comment:2 Changed 2 years ago by ire

  • Cc ire added; iaderinokun removed

comment:3 Changed 2 years ago by juliandoucette

  • Owner set to juliandoucette

comment:4 Changed 2 years ago by juliandoucette

  • Description modified (diff)
  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:5 Changed 2 years ago by juliandoucette

  • Description modified (diff)

comment:6 Changed 2 years ago by abpbot

A commit referencing this issue has landed:
Issue 5379 - Corrected unlocalized hrefs in content

comment:7 Changed 2 years ago by juliandoucette

Note: The previous commit only resolved hrefs not srcs.

comment:8 Changed 2 years ago by juliandoucette

  • Resolution set to fixed
  • Status changed from reviewing to closed

I'm closing this because we only need to localize (make not top level) image paths if images contain text that should be translated. And there are no such images on acceptableads.com.

(Half of this issue has been resolved. The other half was invalid.)

Note: See TracTickets for help on using tickets.