Opened 2 years ago

Closed 2 years ago

#5435 closed defect (fixed)

No search engine is being shown

Reported by: diegocarloslima Assignee: diegocarloslima
Priority: P2 Milestone: Adblock-Browser-for-Android-1.2.0
Module: Adblock-Browser-for-Android Keywords:
Cc: Blocked By:
Blocking: Platform: Adblock Browser for Android
Ready: yes Confidential: no
Tester: Unknown Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29498619/

Description

When typing search terms through the URL input bar, the app should give the user suggestions to perform the search through the different installed search engines. But after abb_fennec_45_0_2_merge, no search engine is being shown as o. Also, when accessing Settings -> Search, no search engine is being listed as installed.

Attachments (2)

search-terms.png (72.0 KB) - added by diegocarloslima 2 years ago.
search-settings.png (88.3 KB) - added by diegocarloslima 2 years ago.

Download all attachments as: .zip

Change History (8)

Changed 2 years ago by diegocarloslima

Changed 2 years ago by diegocarloslima

comment:1 Changed 2 years ago by diegocarloslima

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 2 years ago by abpbot

A commit referencing this issue has landed:
Issue 5435 - No search engine is being shown

comment:3 Changed 2 years ago by diegocarloslima

  • Milestone set to Adblock-Browser-for-Android-1.2.0
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:4 Changed 2 years ago by abpbot

A commit referencing this issue has landed:
Issue 5435 - No search engine is being shown

comment:5 Changed 2 years ago by rscott

  • Resolution fixed deleted
  • Status changed from closed to reopened

Search engines are now being shown, but only 5 of them in total -- the default plus four additional ones. This applies both to the "search bar" in the main browser pane, and to the Settings > Search dialog.

Because more than 5 search engines are installed out of the box, this also makes it look to the user like they can't add additional search providers, since they don't show up anywhere when added.

Build: abb-merge-45-0-2-build-3-signed-zipaligned.apk
Platforms: Google Pixel/Android 7.1.2; ZTE Maven 2 (Z831)/Android 6.0.1

Reproduction:

  1. From a clean install try to add a search engine to ABB, eg Wiktionary:
    • Navigate to https://www.wiktionary.org/
    • Tap the search box at the top of the page.
    • A browser toolbar with magnifying-glass-plus icon should appear. If not, long-press the search box, and it should.
    • Tap the magnifying-glass-plus icon to add Wiktionary as a search provider.
    • An "Add as Search Engine" dialog appears. Tap "OK".
  2. Tap the URL bar and start typing some text in.
  3. Try to swipe the list of search providers left to see the additional ones that aren't displayed.
  4. Observed: only the first four are shown (Yahoo, Google, Wikipedia, Amazon). Wiktionary is nowhere to be seen, and so the user can't use it.
  1. Clear the URL bar and open the Search Settings config dialog (Menu > Settings > Search).
  2. Notice that five search engines are shown: DDG, Yahoo, Google, Wikipedia, and Amazon.
  3. Remove Yahoo by tapping Yahoo > Remove. Repeat for Amazon. Now only three engines are shown.
  4. Back out of the Search page and re-enter (tap the back button, then Search again).
  5. Observed: five search engines are shown: DDG, Google, Wikipedia, Bing, and Twitter.
  6. Remove Bing and Twitter, then back out and re-enter again. Now Wiktionary appears at the end of the list.

Expectation:

  • All installed search engines are shown, both in the search engine bar, and on the Settings > Search config page.
  • All installed search engines are usable.

This bug is not present in Fennec 45.0.2; adding and using any number of search engines seems to work correctly there. nb, though, that FF 45 doesn't always seem to grab the Wiktionary favicon when it's added as a search engine, so it may appear as a generic "magnifying glass" icon in the search bar.

comment:6 Changed 2 years ago by rscott

  • Resolution set to fixed
  • Status changed from reopened to closed
  • Verified working set

After talking with diego about this, this setup is an intentional design decision that was required to reorder the search engines the browser ships with (see ticket #3128). So this is actually working as designed and I'll split my findings out into a separate bug.

Note: See TracTickets for help on using tickets.