Opened 3 months ago

Closed 2 months ago

Last modified 4 weeks ago

#5436 closed defect (fixed)

Relative selectors in :-abp-has() broken

Reported by: hfiguiere Assignee: hfiguiere
Priority: P3 Milestone:
Module: Core Keywords:
Cc: trev, fhd Blocked By: #5404
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29493648/

Description (last modified by hfiguiere)

Environment

In the version of core that is with adblockpluschrome 1.13.3.

How to reproduce

  1. Add a filter with a relative selector inside :-abp-has(), like :-abp-has(> div)

Observed behaviour

This cause a DOM exceptions.

Expected behaviour

No error.

Regression

This is caused by revision 442aa536668a in the 1.13.3 branch. See issue #5404. Also the test has explicitely being removed.

Doesn't happen on master since the relevant patches haven't been grafted yet.

Change History (7)

comment:1 Changed 3 months ago by hfiguiere

  • Description modified (diff)

comment:2 Changed 3 months ago by hfiguiere

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:3 Changed 3 months ago by hfiguiere

  • Blocked By 5404 added

Should be landed after issue #5404 land on master.

comment:4 Changed 2 months ago by abpbot

A commit referencing this issue has landed:
Issue 5436 - Allow relative selectors in :-abp-has()

comment:5 Changed 2 months ago by hfiguiere

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:6 Changed 8 weeks ago by trev

  • Priority changed from Unknown to P3
  • Ready set

comment:7 Changed 4 weeks ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Done. Relative selectors in -abp-has appears to be working correctly again.

ABP 1.13.3.1838
Chrome 51 / 61 / Windows 10
Opera 45 / 47 / Windows 10

Last edited 4 weeks ago by Ross (previous) (diff)
Note: See TracTickets for help on using tickets.