Opened 6 years ago

Closed 5 years ago

#546 closed defect (worksforme)

Adblock Plus and EHH prevent Greasemonkey Installation dialog

Reported by: Gingerbread Man Assignee:
Priority: P3 Milestone:
Module: Adblock-Plus-for-Firefox Keywords:
Cc: smultron45@… Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

Firefox 29.0.1 • Adblock Plus 2.6.1 • Element Hiding Helper for Adblock Plus 1.3 • Greasemonkey 1.15

How to reproduce

  1. In a fresh Firefox profile, install Adblock Plus 2.6.1.
  2. Install Element Hiding Helper for Adblock Plus 1.3.
  3. Install Greasemonkey 1.15 and restart Firefox when prompted.
  4. Visit any user script page and click the Install button, e.g.

http://userscripts.org:8080/scripts/show/163038

Observed behavior

The script opens inside the browser tab, and there's a notification bar with an Install button at the top of the window.

Expected behavior

The browser shouldn't navigate away from the current page (the script shouldn't open in the tab as plain text), and a dialog window titled Greasemonkey Installation should pop up.

Additional notes

Change History (4)

comment:1 Changed 6 years ago by mapx

  • Cc smultron45@… added

comment:2 Changed 6 years ago by philll

  • Priority changed from Unknown to P3
  • Ready set

comment:3 Changed 5 years ago by philll

  • Platform set to Firefox

comment:4 Changed 5 years ago by Gingerbread Man

  • Resolution set to worksforme
  • Status changed from new to closed

I can no longer reproduce this, therefore marking as WORKSFORME.

Firefox 32.0 • Greasemonkey 2.2 • Adblock Plus 2.6.4
Firefox 35.0a1 (2014-09-02) • Greasemonkey 2.2 • Adblock Plus 2.6.4.3861 • Element Hiding Helper 1.3.0.469

New test link (because userscripts.org is defunct):
https://greasyfork.org/scripts/735-anti-adblock-killer-reek

Note: See TracTickets for help on using tickets.