Opened 6 years ago

Closed 4 years ago

Last modified 4 years ago

#549 closed change (fixed)

allow users to enforce ABP being loaded completely at Firefox startup, even if delaying it

Reported by: philll Assignee: trev
Priority: P3 Milestone: Adblock-Plus-2.6.2-for-Firefox
Module: Adblock-Plus-for-Firefox Keywords:
Cc: trev, arthur, mapx Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

http://codereview.adblockplus.org/6744383034490880/

Description

Background

As the start of ABP at Firefox startup is not fast enough to not significantly delay the whole Firefox opening, we decided to let Firefox start even if ABP is not fully loaded yet. Apparently, this leads to pages with ads and tracking in some cases like #418. Until we were able to speed things up sufficiently, we now want to allow the users to choose whether ABP should definitively start with Firefox, even if this delays the whole startup.

What to change

Allow users to enforce ABP being loaded completely at Firefox startup, even if delaying it

Change History (23)

comment:1 Changed 6 years ago by mapx

  • Cc smultron45@… added

comment:2 Changed 6 years ago by trev

  • Owner set to trev

comment:3 Changed 6 years ago by trev

  • Review URL(s) modified (diff)

Added a preference named extensions.adblockplus.please_kill_startup_performance.

comment:4 Changed 6 years ago by trev

  • Status changed from new to reviewing

comment:5 Changed 6 years ago by arthur

  • Cc arthur added

comment:6 Changed 6 years ago by trev

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:7 Changed 6 years ago by trev

  • Component changed from Unknown to Adblock-Plus-for-Firefox
  • Milestone set to Adblock-Plus-for-Firefox-next

comment:8 Changed 6 years ago by kilara1988

The pref does not work for me.Actually i think it did only once after i turned it on.Tested on new profile with same results.

Windows 7 x64
Nightly 32.0a1 (2014-05-26)

comment:9 Changed 6 years ago by philll

Hm, works for me with same nightly on 32 bit Win7

comment:10 Changed 6 years ago by illbeatzanys

Windows 7 x64
Firefox 29.0.1

After installing the latest ABP dev build and changing the FF preference, ABP appeared to work as desired after its first restart. All subsequent restarts resulted in ads being loaded on various pages.

comment:11 Changed 6 years ago by trev

This preference effectively reverts changes made in #117 but not in #153. So while the processing happens synchronously with it, reading from hard drive doesn't. Reading the data was asynchronous before #153 as well, it just wasn't implemented too well so pages loading before the data was read was a rare occasion - apparently not any more. I assume that a slow hard drive and large data files (many filter subscriptions) make it more likely to happen.

Blocking Firefox on an async operation is complicated to say the least, it will likely lead to crashes and other stability issues. In other words, we would need a separate, synchronous reading path triggered by this preference - not really something I would be happy with.

comment:12 Changed 6 years ago by Trevor

To bad this update didn't seem to fix it for anyone :/

So whats next? are you working on a fix that we can test soon?

comment:13 follow-up: Changed 5 years ago by philll

falsly spam-blocked comment by Einstein:
The fix does not work. I've tried on two different computers with FF29 and FF30.
Can this be fixed?
Thanks

comment:14 in reply to: ↑ 13 Changed 5 years ago by Einstein

Replying to philll:

falsly spam-blocked comment by Einstein:
The fix does not work. I've tried on two different computers with FF29 and FF30.
Can this be fixed?
Thanks

Thanks for pasting my message (which got blocked).
Any response? Is there anyone monitoring items which were closed?

Thanks

comment:15 Changed 5 years ago by gwt

Why does this ticket say it's fixed? It's not fixed!

Constant bypass of filters on MSN - MSN.com has been my home page for years.

I also remember a time in the recent past when Adblock and Firefox loading together simultaneously was never an issue. Wouldn't mind going back to that. Even if it means waiting another 2 or 3 seconds for Firefox to load. I'd rather have a slightly slower Firefox startup than have to put up with shitty ads from the likes of Capital One and Visa.

These ads don't always disappear after loading unless I hit F5 and reload the browser page.

Last edited 5 years ago by gwt (previous) (diff)

comment:16 Changed 5 years ago by hajj_3

  • Resolution fixed deleted
  • Status changed from closed to reopened

This issue is NOT fixed!

comment:17 in reply to: ↑ description Changed 5 years ago by dookdookdook

Got a brand new laptop 3 days ago, installed FF 31 and ABP 2.6, and ads were blocked 50% of the time if I was lucky. Had to downgrade all the way to 2.2.4 - the version on my desktop - before it would work reliably again. Just going back to 2.5 didn't change anything.

If this is your idea of improving your product, please just stop. 2 extra seconds on the FF startup time is nothing compared to how much cumulative time I wind up wasting waiting for ads to load.

comment:18 Changed 5 years ago by tempuser1231

I opened an issue related to privacy and security, which got closed as a duplicate of this one. I don't feel the discussion here matches the gravity of the issue, and there is no indication of progress or if it is being worked on. As I wrote in the other issue, privacy and security are two of Adblock's main features according to the web site, and currently they don't work reliably. Even with the hidden "extensions.adblockplus.please_kill_startup_performance" option set, pages get loaded before Adblock is ready. The result is that tracking cookies are set, tracking servers are pinged, ads (which may include malware) are loaded, social networks get more info through their buttons, etc.

Seeing slow startup described as "certainly worse" than having unreliable privacy and security in #418 isn't reassuring. Could the authors please clarify their stances on privacy and security on the blog? If they don't care about it, please don't advertise the features on the web site. After all, what good would security tools like a firewall be if it didn't reliably block connections?

Also, why does the option have a negative and misleading name? It would be more precise to call it "please don't jeopardise privacy and security without telling the user", which maintains the tongue-in-cheek rather nicely.

comment:19 Changed 5 years ago by dimentiyinfo

Fix NOT working.
ff 31.2.0esr, abp 2.6.5

My firefox startup option set to "Show my windows and tabs from the last time". So I see ads on every browser restart. 100% reproduced.

comment:20 Changed 5 years ago by mapx

  • Cc mapx added; smultron45@… removed
  • Platform set to Unknown

comment:21 Changed 4 years ago by greiner

  • Resolution set to fixed
  • Status changed from reopened to closed
  • Tester set to Unknown

The mentioned fix has already landed so this ticket should not be reopened. Please create a new ticket if this issue still occurs.

comment:22 Changed 4 years ago by tempuser1231

New ticket #2957

comment:23 Changed 4 years ago by tempuser1231

#2957 was closed as a duplicate due to misunderstanding, new ticket at #3046

Note: See TracTickets for help on using tickets.