Opened 3 months ago

Closed 6 weeks ago

#5518 closed change (fixed)

Add Ecosia as secondary search engine

Reported by: diegocarloslima Assignee: jwangenheim
Priority: P3 Milestone: Adblock-Browser-for-Android-1.3.0
Module: Adblock-Browser-for-Android Keywords:
Cc: Blocked By:
Blocking: Platform: Adblock Browser for Android
Ready: yes Confidential: no
Tester: Unknown Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29538584/
https://codereview.adblockplus.org/29556775/
https://codereview.adblockplus.org/29556772/

Description (last modified by diegocarloslima)

Background

As previously discussed, we'll add Ecosia as secondary search engine in ABB.

For future reference, how search engines work in Adblock Browser
https://docs.google.com/document/d/1REO72MFtHE6mTPTdxa6J1rHQflvQwPI4NAiY6I2htIA/edit#

What to change

1) Add Ecosia to the list of installed default search engines. See attached search plugin configuration.

2) Make it available only on a few specific countries/locales:

  • US (US)
  • UK (GB)
  • France (FR)
  • Netherlands (NL)
  • Germany (DE)
  • Austria (AT)
  • Switzerland (CH)

These markets are the markets where Ecosia has the biggest number of users, so makes sense we only show this search engine for those users.

3) Priority-wise, for the countries defined in 2), should be the following: Ecosia comes before Wikipedia and Amazon. This is because Ecosia is a general-purpose engine, unlike Wikipedia or Amazon.

Hints for testes

To verify if this is working, put the device under one of those above listed locales and go to Settings -> Search and check if Ecosia is listed as one of the Installed search engines

Attachments (7)

ecosia.xml (1.7 KB) - added by diegocarloslima 3 months ago.
Logo_icon_64px (1).zip (18.3 KB) - added by tpregueiro 7 weeks ago.
Ecosia Logos
IMAGE 2017-10-02 10:31:24.jpg (43.5 KB) - added by tpregueiro 7 weeks ago.
Ecosia pixelated icon
Screenshot_20171012-054153.png (96.5 KB) - added by traynard 6 weeks ago.
English (UK) Search Engine list
Screenshot_20171012-085747.jpg (221.4 KB) - added by jwangenheim 6 weeks ago.
Screenshot_20171012-085808.jpg (176.1 KB) - added by jwangenheim 6 weeks ago.
Screenshot_20171012-085842.jpg (188.1 KB) - added by jwangenheim 6 weeks ago.

Download all attachments as: .zip

Change History (28)

Changed 3 months ago by diegocarloslima

comment:1 Changed 3 months ago by diegocarloslima

  • Description modified (diff)

comment:2 Changed 3 months ago by jwangenheim

  • Owner set to jwangenheim

comment:3 Changed 3 months ago by tpregueiro

  • Description modified (diff)

comment:4 Changed 3 months ago by tpregueiro

  • Description modified (diff)

comment:5 Changed 3 months ago by jwangenheim

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:6 Changed 2 months ago by abpbot

A commit referencing this issue has landed:
Issue 5518 - Add Ecosia as secondary search engine

comment:7 Changed 2 months ago by jwangenheim

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:8 Changed 2 months ago by diegocarloslima

  • Milestone set to Adblock-Browser-for-Android-next

comment:9 Changed 2 months ago by diegocarloslima

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:10 Changed 2 months ago by diegocarloslima

  • Review URL(s) modified (diff)
  • Status changed from reopened to reviewing

comment:11 Changed 8 weeks ago by diegocarloslima

  • Description modified (diff)

Changed 7 weeks ago by tpregueiro

Ecosia Logos

Changed 7 weeks ago by tpregueiro

Ecosia pixelated icon

comment:12 Changed 7 weeks ago by tpregueiro

@diego @jens a couple of minor issues re: ecosia integration

1) I noticed the icon we're using doesn't seem to have the appropriate resolution, and appears a bit pixelated. see https://issues.adblockplus.org/attachment/ticket/5518/IMAGE%202017-10-02%2010%3A31%3A24.jpg

Ecosia has sent a zip file with more icon files so that we can pick the correct one. If we need a different specific image size pls let me know.
https://issues.adblockplus.org/attachment/ticket/5518/Logo_icon_64px%20(1).zip

2) the Ecosia team has run some test and they had the following [feedback:

We've taken a look and noticed that the installation link we sent you earlier this year has tracking we are no longer using. Below is the updated one, please could you use this one instead of the one with the ref tag: 

https://www.ecosia.org/search?tt=abp&q=<term>

Could we update the URL to the contain the latest tracking tag?

Thanks.

comment:13 Changed 7 weeks ago by diegocarloslima

@tpregueiro:

1) I just noticed that although all other search engines .xml files specifies the icon as 16x16, the actual base64 icon is 96x96. I'll adjust Ecosia's base64.

2) I'll update the URL in the .xml file.

Last edited 7 weeks ago by diegocarloslima (previous) (diff)

comment:14 Changed 7 weeks ago by abpbot

A commit referencing this issue has landed:
Issue 5518 - Add Ecosia as secondary search engine

comment:15 Changed 7 weeks ago by abpbot

A commit referencing this issue has landed:
Issue 5518 - Add Ecosia as secondary search engine

comment:16 Changed 7 weeks ago by diegocarloslima

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:17 Changed 6 weeks ago by traynard

  • Resolution fixed deleted
  • Status changed from closed to reopened

"Priority-wise, for the countries defined in 2), should be the following: Ecosia comes before Wikipedia and Amazon."

This is not always the case. In a language where Amazon is included as a search engine (English US and UK, Deutsch), Amazon is prioritized above Ecosia. Amazon generally takes first or second position below default while Ecosia takes third or fourth.

Wikipedia's priority is shown as expected.

Last edited 6 weeks ago by traynard (previous) (diff)

Changed 6 weeks ago by traynard

English (UK) Search Engine list

comment:18 Changed 6 weeks ago by jwangenheim

hey tasha,

I tried to reproduce the issue but for me the search engine order is as expected for all three languages (see attached screenshots). which APK did you use for the test? I used adblockbrowser-1.3.0.20171004094541-arm-standalone-signed.apk with MD5 de3062d94564138d41a86d3fad00b28e

Changed 6 weeks ago by jwangenheim

Changed 6 weeks ago by jwangenheim

Changed 6 weeks ago by jwangenheim

comment:19 Changed 6 weeks ago by traynard

hey, I am using adblockbrowser-1.3.0-arm.apk, the latest store release posted in ABB channel. Looks like i may be on an old build :|

Last edited 6 weeks ago by traynard (previous) (diff)

comment:20 Changed 6 weeks ago by traynard

  • Verified working set

Working in the latest build.

comment:21 Changed 6 weeks ago by traynard

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.