#5521 closed change (fixed)

Restructure CMS documentation to make it easier to use and extend

Reported by: kvas Assignee: ire
Priority: Unknown Milestone:
Module: Sitescripts Keywords:
Cc: ire, juliandoucette, jsonesen, wspee Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29628724

Description

Background

Even though the functionality of CMS is relatively well documented, the included README file is not comprehensive enough for new users or for understanding all details of the intended behavior. At the same time, the content of README is too long and detailed for a readme file. Most people would expect README to give just the basic overview of the software.

Both of these problems can be solved by creating additional documentation pages. Not so basic parts of README could then be moved to such pages and extended with additional details and examples.

What to change

Restructure existing documentation in the README to allow for future growth and extension:

  • Create docs/ folder in the root folder.
  • Split the non-basic parts (DETERMINE WHICH ONES) of the README out into separate pages in the docs/ folder and link them from the README.

Change History (5)

comment:1 Changed 20 months ago by ire

@kvas : Sounds great to me! How should we proceed?

comment:2 Changed 17 months ago by ire

  • Owner set to ire
  • Ready set

comment:3 Changed 17 months ago by ire

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:5 Changed 16 months ago by ire

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.