Opened 2 years ago

Closed 2 years ago

#5561 closed change (duplicate)

Redirect unknown locales to english

Reported by: wspee Assignee:
Priority: Unknown Milestone:
Module: Infrastructure Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Background

Our products often refer to our websites to provide the user with additional information. If possible we want to show this information in the same language the user is using the product. But our products might be translated to language that is not available on our website. In this case the user currently gets a 404 page. Ideally we would like to fallback to English. All websites are always available in English and we assume this is the most likely understood fallback language. It's not feasible to introduce a dependency between the product and the website so that the product can decide which language to use.

What to change

If a website was requested in a locale that is not supported redirect to English instead.

Change History (3)

comment:1 Changed 2 years ago by wspee

  • Component changed from Unknown to Infrastructure

Unsure about the module, assuming Infrastructure for now.

comment:2 follow-up: Changed 2 years ago by ferris

Is this perhaps a duplicate of #3183?

comment:3 in reply to: ↑ 2 Changed 2 years ago by wspee

  • Resolution set to duplicate
  • Status changed from new to closed

Replying to ferris:

Is this perhaps a duplicate of #3183?

I think you are right.

Note: See TracTickets for help on using tickets.