Opened 5 years ago

Closed 5 years ago

#559 closed defect (incomplete)

1) the filter lists automatically disappear and 2) the Adblock Plus icon and menu option disappear!!

Reported by: MichaelIsGreat Assignee:
Priority: Unknown Milestone:
Module: Adblock-Plus-for-Firefox Keywords:
Cc: smultron45@…, trev Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

Windows 7 Ultimate 64-bit; Firefox 29; EasyList, EasyPrivacy; Adblock Warning Removal List.

How to reproduce

I cannot reproduce this HUGE BUG 1) in a set of clear steps because it happens overtime automatically! Same for bug 2).

Observed behaviour

As I said in the summary:
1) My three filter lists (EasyList, EasyPrivacy; Adblock Warning Removal List) automatically disappear. IT IS A HUGE BUG. It happens with me not doing anything particular to have my filter lists disappear.
I unexpectedly simply see a few ads on a web page, then I check the filter lists and discover that nothing is listed anymore! And I certainly did not do anything to have these three filter lists unlisted!!
The last time I saw this happening, I was on http://slashdot.org/?source=autorefresh .

2) the Adblock Plus icon and menu option disappear!!
Again, I do not do that, it simply happens and I do not know how.

Expected behaviour

Well, that is obvious.
1) I expect my filter lists to stay listed, not be unlisted automatically without me knowing!
2) Same, I expect my Adblock menu option in Tools and my Adblock icon not to disappear automatically without me doing anything to have this bug happen!

Remark: to ask users to register just to send a bug comment is unrealistic, it is pure madness and I am surely mad doing that because I would never thought I would have registered just to inform you of a bug. Only the most mad people like me register for a bug comment!

Attachments (2)

My addons (all) on 05.26.2014.jpg (160.9 KB) - added by MichaelIsGreat 5 years ago.
My list of addons on 05.26.2014.
My Adblock Plus subscribed filters (4) and my Adblock Plus custom filters (3) (on 2014.06.03).jpg (350.3 KB) - added by MichaelIsGreat 5 years ago.
My Adblock Plus subscribed filters (4) and my Adblock Plus custom filters (3) (on 2014.06.03).

Download all attachments as: .zip

Change History (14)

comment:1 Changed 5 years ago by mapx

  • Cc smultron45@… added
  • Component changed from Unknown to Adblock-Plus-for-Internet-Explorer

what other addons are installed in your firefox ?

comment:2 Changed 5 years ago by philll

  • Component changed from Adblock-Plus-for-Internet-Explorer to Unknown

I don't see any connection to Internet Explorer so far?

comment:3 Changed 5 years ago by mapx

oh, my fault

comment:4 Changed 5 years ago by mapx

  • Component changed from Unknown to Adblock-Plus-for-Firefox

Changed 5 years ago by MichaelIsGreat

My list of addons on 05.26.2014.

comment:5 Changed 5 years ago by MichaelIsGreat

I have a very strong feeling that the culprit is a site http://www.kickassunblock.info/ that I use regularly. Just now, I used it and I saw the ads showing up. I checked and here again all the filters were gone and the Adblock Plus icon on the taskbar at the bottom of Firefox 29 was gone too as well as the Adblock Plus menu option that I have on Tools.

That is quite scary that your addon has managed to be totally circumvented!!

For the the Adblock Plus icon on the taskbar at the bottom of Firefox 29 and the Adblock Plus menu option, I can easily get them back by doing Toolbars, check the Addon toolbar, then tick the option in Tools, Addons for Adblock Plus saying "Show in Toolbar" that is systematically unticked when your addon is circumvented.

Keep me informed of your discoveries and if I have been of any help. That your addon has managed to be circumvented is inadmissible to me and I hope you will find the culprit soon.

Many thanks for your detective work on this matter and I will try to help you out.

comment:6 Changed 5 years ago by mapx

Did you try doing your tests disabling all other addons ? I tried that site (kick...) and no issues here.

comment:7 Changed 5 years ago by MichaelIsGreat

The problem disabling all the other addons long-term (I only tried for two days and nothing was changed) is that the appearance of this problem of having my list of filters in Adblock Plus basically disappear without me doing anything to trigger such a problem is that it seems to be completely random (except when I noticed recently when it occurred while visiting the kick... site).
Therefore, I do not see how I could keep having my other addons disabled long-term with the hope of not seeing this problem appear again or of seeing it appear again.
More, for several of my addons, I need them regularly when I browse the Internet.

Also, you have seen my list of addons on the jpg that I provided. They are not the type of addons to mess around in such a targeted way with your particular addon.

It is strange this problem. Very weird and the strangest is that the cause of it seems completely elusive so far.

So far, this problem has occurred maybe five times in all, not more. So, it is not something that appears often and regularly.

comment:8 Changed 5 years ago by mapx

well, obviously I asked you to disable the other addons only to see / find which one could have a wrong behaviour.

It's weird you can not reproduce the issue every time.
You could keep enabled only the strictly necessary addons (for example are you always using session manager or theme restorer ?) and see if happens again.

Another idea would be a new clean profile (reinstalling your addons)
http://kb.mozillazine.org/Creating_a_new_Firefox_profile_on_Windows

Changed 5 years ago by MichaelIsGreat

My Adblock Plus subscribed filters (4) and my Adblock Plus custom filters (3) (on 2014.06.03).

comment:9 Changed 5 years ago by philll

By MichaellsGreat:
Today, visiting youtube.com, I saw a video that had a ad. I stopped, check Adblock plus and

saw that my subscribed filters were gone as well as my custom filters! I reinstalled only my

subscribed filters and strangely my custom filters reappeared without me doing anything!!
I would not be very surprised if Google was behind this BIG problem.

I leave a jpeg showing my subscribed filters and custom filters.

comment:10 Changed 5 years ago by philll

  • Platform set to Firefox

comment:11 Changed 5 years ago by trev

  • Cc trev added

Looking at your list of installed add-ons, Classic Theme Restorer would be the prime suspect for the second issue you listed ("Adblock Plus icon and menu option disappear").

Unfortunately, I have a hard time imagining what would cause the filters to disappear during a browsing session. Please go to chrome://adblockplus/content/errors.html next time after this happens - does it show any errors?

comment:12 Changed 5 years ago by trev

  • Resolution set to invalid
  • Status changed from new to closed

No answer in a while, resolving as invalid - this issue isn't reproducible.

Note: See TracTickets for help on using tickets.