Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#5590 closed defect (fixed)

[webextension] Custom filters in the options page aren't updated

Reported by: trev Assignee: trev
Priority: P2 Milestone: Adblock-Plus-1.13.4-for-Chrome-Opera
Module: Platform Keywords:
Cc: mjethani, sebastian, kzar Blocked By:
Blocking: #5386 Platform: Firefox
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29531596/

Description (last modified by trev)

Environment

Firefox 55, Adblock Plus 2.99.0.1822

How to reproduce

  1. Open Adblock Plus Options.
  2. Switch to the "Add your own filters" tab.
  3. Enter "test" as filter and click "Add filter"

Observed behaviour

The new filter doesn't show up in the list, only after reloading the page. Removing filters doesn't show an immediate effect either.

Expected behaviour

New filter should be added to the list.

Hints for testers

#5589 has the same root cause and should be retested along with this issue. Also, #5386 needs to be retested to make sure that we didn't regress it.

Change History (14)

comment:1 Changed 2 years ago by kzar

  • Cc mjethani sebastian kzar added
  • Priority changed from Unknown to P2
  • Ready set

comment:2 Changed 2 years ago by sebastian

I tried to reproduce this issue in Firefox 53. However, the bahavior I reproduced there diverges from what is reported in this issue. The filters are add/removed but with a significant delay.

comment:3 Changed 2 years ago by trev

No, in Firefox 55 and 57 the filter is definitely not being added at all. It's probably related to the following message I see showing up twice when the options page is loaded:

Unchecked lastError value: Error: Could not establish connection. Receiving end does not exist.

Stack trace is useless unfortunately.

comment:4 Changed 2 years ago by trev

Actually, in Firefox 57 the filter isn't being added at all, it doesn't show up after reloading either.

Edit: Never mind, they are being added. They merely don't show up at the end of the list.

Last edited 2 years ago by trev (previous) (diff)

comment:5 Changed 2 years ago by trev

  • Owner set to trev

It seems that messages from background page to options page aren't being received. Seems to be similar to https://bugzilla.mozilla.org/show_bug.cgi?id=1380290, not quite the same issue however.

comment:6 Changed 2 years ago by trev

  • Blocking 5386 added

Not a Firefox bug after all, rather a regression from #5386.

comment:7 Changed 2 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:8 Changed 2 years ago by trev

  • Description modified (diff)

comment:9 Changed 2 years ago by mjethani

FWIW I just retested #5386 with the proposed patch applied and it works fine.

comment:10 Changed 2 years ago by abpbot

A commit referencing this issue has landed:
Issue 5590 - [webextension Custom filters in the options page aren't updated]

comment:11 Changed 2 years ago by trev

  • Milestone set to Adblock-Plus-for-Chrome-Opera-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:12 Changed 2 years ago by trev

  • Description modified (diff)

comment:13 Changed 2 years ago by Ross

Fixed. Filters are added to the list.

ABP 1.13.13.1838
Chrome 49 / 60 / Windows 7
Opera 36 / 46 / Windows 7

ABP 2.99.0.1838beta
Firefox 55 / Windows 7

comment:14 Changed 2 years ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set
Note: See TracTickets for help on using tickets.