#5625 closed defect (duplicate)

ABP Safari not blocking and/or unblocking detection pixels

Reported by: esanchez Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: esanchez, sebastian, kzar Blocked By:
Blocking: Platform: Safari
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

osX Sierra 10.12.4 (did not test others)
Safari 10.1 (did not test others)
ABP 1.12.1 and 1.12.4.1825

Local filters:

@@||a2gw.com^$script,domain=localhost
@@||a2gw.com^$script,domain=demo.ad2games.com
@@||a2gw.com/px.gif?ch=1
||a2gw.com/px.gif?ch=2

How to reproduce

  1. Go to http://demo.ad2games.com/abp.html with no local filters
  2. Go to the JS console and run this: ad2games.detect('/img/p.gif', function(usesABP) {console.log(usesABP)}), it will return false which is correct.
  3. add the local filters listed above here.
  4. run again: ad2games.detect('/img/p.gif', function(usesABP) {console.log(usesABP)}) it will return false and that is not correct.

...

Observed behaviour

AA Detection script returns false regardless.
note: Works fine on Chrome and Firefox

Expected behaviour

AA detection script should return true when px.gix?ch=1 is whitelisted and px.gif?ch=2 is blocked

Change History (5)

comment:1 Changed 23 months ago by sebastian

  • Cc sebastian added
  • Component changed from Core to Platform

comment:2 Changed 23 months ago by sebastian

  • Cc kzar added

Is this possibly a duplicate of #4384?

comment:3 Changed 23 months ago by sebastian

  • Platform changed from Unknown / Cross platform to Safari

comment:4 Changed 23 months ago by esanchez

It is very possible this is a duplicate of 4384, I forgot about it.
I'll check if we can work around this.
Do we mark this one as duplicate and close it for now?

comment:5 Changed 22 months ago by sebastian

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.