Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#5649 closed defect (fixed)

AppxMainfest.xml includes truncated version umber

Reported by: sebastian Assignee: sebastian
Priority: P2 Milestone: Adblock-Plus-3.0-for-Firefox
Module: Automation Keywords:
Cc: oleksandr, tlucas Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29540555

Description (last modified by sebastian)

How to reproduce

Run ./build.py -t edge -b 1234 (or inspect the devbuild from the Windows Store)

Observed behaviour

The version attribute in the Identity node in AppxMainfest.xml is set to 0.9.11.0, while the version number given in the build's filename and manifest.json file includes the build number as 4th component.

The incomplete version number from AppxMainfest.xml also shows up in the Windows Store developer dashboard.

That is because the version given in the metadata file is overriding the final version number already given in params, when AppxMainfest.xml is generated.

Expected behaviour

AppxMainfest.xml and manifest.json should include the same version number, with the build number (provided by the -b option) in the 4th component.

Change History (7)

comment:1 Changed 2 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 2 years ago by sebastian

  • Description modified (diff)

comment:3 Changed 2 years ago by abpbot

A commit referencing this issue has landed:
Issue 5649 - Include full version number in AppxManifest.xml

comment:4 Changed 2 years ago by sebastian

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:5 Changed 2 years ago by abpbot

comment:6 Changed 2 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-next

comment:7 Changed 2 years ago by sebastian

For reference, while the version being truncated seem to have been an accident (or at least happened through a rather non-obvious coding practice), this is actually necessary due to restrictions of the Windows Store, see #5666. Also see #5668 for another related issue.

Note: See TracTickets for help on using tickets.